cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

Félix_T
Contributor

I am trying bring up a new board that we have made using an Azurewave AH-306. When scanning, the chip immediately returns from the scan with the response WLC_E_STATUS_ABORT.

Our previous development board does not do with with the exact same code.  

Does anyone have an idea for what causes the WiFi chip to return WLC_E_STATUS_ABORT on every scan?

0 Likes
1 Solution
Zhengbao_Zhang
Moderator
Moderator

Hello:

  It is better to check 26/37.4M clock, LPO clock ,  VDDIO, SDIO interface related..

and better to provide more specific logs ,  AH-306 is 43455 ?

View solution in original post

0 Likes
3 Replies
Zhengbao_Zhang
Moderator
Moderator

Hello:

  It is better to check 26/37.4M clock, LPO clock ,  VDDIO, SDIO interface related..

and better to provide more specific logs ,  AH-306 is 43455 ?

View solution in original post

0 Likes
Félix_T
Contributor

AH-306 is a 43012. Which logs do you want to know about? We are running this chip against a custom board, we have not enabled wiced logging.

The chip seems to come up OK. If the SDIO interface were not working, we would not have been able to bring up the chip (including loading the firmware and sending the configs). We are not seeing any other errors until wwd_wifi_scan is called and in our registered scan_result_handler, we get a status of WICED_SCAN_ABORTED. I went up one stack frame into wwd_scan_events_handler and there is where I see that the scan abort is due to a scan status of WLC_E_STATUS_ABORT.

 

We will be doing X-rays on the board today to see if we have a broken trace.

0 Likes
Félix_T
Contributor

We had extra resistors on some of the VDD(x) lines which caused the issue.

0 Likes