cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

MichaelF_56
Moderator
Moderator

The new 3.7.0-3 release includes fixes for the following issues found in the original 3.7.0 release:

  1. Gedday/mDNS stability fixes
  2. Updated mDNS Service Discovery snip app to demonstrate service discovery
  3. OTA2 stability fixes
  4. Resolved memory leaks in BESL library
  5. Support for Bluetooth Low Power Mode on 4343x platforms
  6. Support for PEAPv0/EAP-TLS Enterprise security on BCM4390x platforms
  7. Fix for Bluetooth LE pairing failure after configuring Bluetooth address

You can download the new SDK here:

0 Likes
14 Replies
AxLi_1746341
Honored Contributor

There are 2 major issues needs fix:

1. BESL memory leak

2. WPS does not work

I guess you need to make an urgent fix soon.

Please make sure your team fixes these issues in next release as they are *regressions*.

AxLi_1746341
Honored Contributor

Actually, I'm worried about the timing to get the fix.

I have been waiting very long time for new SDK release to address memory leak issue.

I don't understand why it takes such a long time to fix regression issues.

These regressions are killing new projects using WICED SDK.

Anonymous
Not applicable

Hello

0 Likes
AxLi_1746341
Honored Contributor

Vikas Shah wrote:

Hello

vsha

I just use https_client snip, the code I changed is simply adding a while loop to send requests.

Does it ever work for you without memory leak?

Anonymous
Not applicable

HI

We have verified with "TLS_DHE_RSA_WITH_AES_256_CBC_SHA256" [ Disabling all other cipher suites except one in wiced_tls.c ]  cipher suite by connecting to server and confirmed that no memory leak present and https get in while loop works reliably.

By default, server picks " ECDHE-RSA" cipher suite and memory leak present in that path. We will look into this and provide the fix.

AxLi_1746341
Honored Contributor

By default, server picks " ECDHE-RSA" cipher suite and memory leak present in that path. We will look into this and provide the fix.

Good to know the progress.

Hope the fix will be available soon.

Thanks,

Axel

0 Likes
AxLi_1746341
Honored Contributor

vsha

Please make sure you have tested all supported cipher suite before release.

Anonymous
Not applicable

Sure. We will test all supported cipher suite before release.

Anonymous
Not applicable

Since the WICED IDE is eclipse based. Is there a plugin that I can install in my already existing eclipse in linux? Because the quick start guide just mentions windows and I'm working on linux natively and I can't find any section talking about how to install the IDE or some sort of plugin in Linux.

Thanks!

0 Likes
MichaelF_56
Moderator
Moderator

I am not aware of a plugin that accommodates what you are requesting.

However, I know that once you install one version of the SDK on Linux, you can then upgrade to subsequent versions using these instructions: How to import a WICED SDK into an existing WICED Eclipse IDE (2)

For example, you could install the Linux version here: WICED™ Software Development Kit: WICED-SDK-2.4.1.7z [SDK Only - Windows, OS X, Linux]

Then use the files from the .7z upload (WICED SDK 3.7.0-3 .7z Source files​) for the latest version and upgrade.

Anonymous
Not applicable

Thank you!

I was able to port the project from WICED IDE on windows to my already existing eclipse installation. It is compiling fine and also I can compile and download the project to my eval board. Nevertheless, I'm having problems for debugging the board.

I have copied the debug configurations from the windows ide and I'm getting the following error:

Error in final launch sequence

Failed to execute MI command:

-target-select remote localhost:3333

Error message from debugger back end:

localhost:3333: Connection timed out.

localhost:3333: Connection timed out.

In Windows, I can debug just fine but in Linux, I have this problem. I'm testing this out in a VM so no, I'm not using windows and I have to make this work on my Linux IDE.

Do you know what could be wrong or what I am missing?

Thanks again for helping!!

0 Likes
Anonymous
Not applicable

Hi Manuel,

How you looked at this?

Setup Eclipse Kepler for WICED SDK on Linux - Ubuntu 14.04 or 12.04

With above you should be able to get it to work on Linux.

I haven't used a VM myself, but VM shouldn't be a problem. You need to make sure though that the guest owns the USB devices on the WICED board (JTAG and Serial port) .

Anonymous
Not applicable

Hello vsb

I followed the steps in the mentioned link but I still have the same error. I have always make sure that the OS where I'm trying to use the debugger is the one that owns the USB device. I did the last test without having the VM just to make sure and I still experience the same issue.

0 Likes
AxLi_1746341
Honored Contributor

mwf_mmfae wrote:

The new 3.7.0-3 release includes fixes for the following issues found in the original 3.7.0 release:

  1. Gedday/mDNS stability fixes
  2. Updated mDNS Service Discovery snip app to demonstrate service discovery
  3. OTA2 stability fixes
  4. Resolved memory leaks in BESL library
  5. Support for Bluetooth Low Power Mode on 4343x platforms
  6. Support for PEAPv0/EAP-TLS Enterprise security on BCM4390x platforms
  7. Fix for Bluetooth LE pairing failure after configuring Bluetooth address

Just to remind you that above changes are not included in the CHANGELOG.txt file.

0 Likes