cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

10 Replies
Anonymous
Not applicable

Hi

I am trying to debug my BCM943362WCD4_EVB "out of the box" with the OSX SDK 3.1.1 but Eclipse can not connect.

I there som OSX drivers that is necessary to install separately?

Thank you for any hints.

0 Likes
Anonymous
Not applicable

I get this error messages:

Downloading Bootloader ...

**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****

Downloading DCT ...

**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****

Downloading Application ...

**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****

Build complete

0 Likes
VikramR_26
Employee

Hi Bertil,

I tried reproducing and did not see any issue. Could you make sure your installation was successful.

thnx,

vik86

0 Likes
MuOr_1658816
Contributor

I ran into this issue too. You need to set certain files as executable. Sometimes the installation doesn't do that correctly.

0 Likes
SuMa_296631
Contributor II

As I'm getting exactly this, can you tell us what files need to be set executable and where they are located?

Susan

0 Likes
Anonymous
Not applicable

can you please tell us the files that need to be set? Thank you

0 Likes
MuOr_1658816
Contributor

i don't recall which ones i set executable, but there were a few. you'll need to look at the logs to see what it is trying to execute.

0 Likes
Anonymous
Not applicable

To confirm this, I have purchased a new MacBook Air (Yosemite 10.10.1 (14B25)).

-Nothing is installed on the new Mac.

-Installed WICED SDK 3.1.1

-Plugged in  BCM943362WCD4_EVB

-Blue JTAG led and Green 3V3 led is on.

When I execute "snip.scan-BCM943362WCD4 download run". I still get the following error. Any comments would be appreciated.

Downloading Bootloader ...

**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****

Downloading DCT ...

**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****

Downloading Application ...

**** OpenOCD failed - ensure you have installed the driver from the drivers directory, and that the debugger is not running **** In Linux this may be due to USB access permissions. In a virtual machine it may be due to USB passthrough settings. Check in the task list that another OpenOCD process is not running. Check that you have the correct target and JTAG device plugged in. ****

Resetting target

make[1]: *** [run] Error 1

make: *** [main_app] Error 2

---------

also openocd_log.txt log is;

Info : only one transport option; autoselect 'jtag'

trst_and_srst separate srst_nogate trst_push_pull srst_push_pull connect_assert_srst

adapter speed: 1000 kHz

adapter_nsrst_delay: 100

jtag_ntrst_delay: 100

Warn : target name is deprecated use: 'cortex_m'

jtag_init

Error: unable to open ftdi device: device not found

in procedure 'init'

0 Likes
Anonymous
Not applicable

I have been investigating a bit on this, and found that first of all the VID/PID located in the BCM9WCD1EVAL.cfg does not match the actual VID/PID of the FTDI chip on the EVK. In my case it was 0x0403/0x6010. I fixed the line in the .cfg file:

#ft2232_vid_pid 0x0a5c 0x43fa

ft2232_vid_pid 0x0403 0x6010

The BCM9WCD1EVAL.cfg file is located in /Applications/WICED/WICED-SDK-MFi-3.1.2/tools/OpenOCD/

This results in the opened_log.txt indicating a new error: (device already in use) or something similar. This is because the Mac OS X Yosemite have been released with a AppleFTDI driver pre-installed. This driver takes over the FTDI interface towards the WICED DVK. I followed the instructions in this link:

http://alvarop.com/2014/01/using-busblaster-openocd-on-osx-mavericks/

Even though it describes the problem in Maverics, it applies to Yosemite also.

You might want to restart your Mac OS X before unloading the Apple FTDI drivers (Kernel Extensions), at least I needed to.

Then when you have successfully programmed the WICED DVK, you can safely reload the Apple FTDI drivers and use the CoolTerm to start looking af printf()'s from the device.

A final note: Unloading the Apple FTDI drivers will make all other FTDI devices (UART) un-useable during that period.

0 Likes
SuMa_296631
Contributor II

I found that I needed to follow the instructions elsewhere on the internet (Getting JTAG and serial port to work under Mac OS X using an Olimex ARM-USB-OCD : CrossWorks Support) , editing the remaining Olimex entry to get the PID and VID numbers to match( I was usign the Olimex ARM-USB-TINY-H JTAG programmer) and not stopping when the system told me the kext was not originally loaded but loaded the new one.

One thing that helped me was to add "VERBOSE=1" to the "make target" command line so I could track down the actual command line that was being used. There were several parts to the command and I was able to try the separate parts to isolate the problem command.

At one stage I needed to reboot my computer (it crashed but I *think* it was unrelated to this as it has not happened again) and needed to load the kext file after the reboot. If that is what it takes then it is a small price in my mind.

In my case, I have several other FTDI devices that provide serial TTY devices and they have continued to work correctly after performing the above actions.

Susan