Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Wi-Fi Combo Forum Discussions

aktac_3789331
Level 2
Level 2

Hi Support,

I am evaluating the cypress CYW943907AEVAL1F board. Mostly I want to go for the wireless power save mode. I am following the document given at the link: Low Power Current Measurements Using CYW943907AEVAL1F  .

As mentioned in the document I am using an example 43xxx_Wi-Fi/apps/test/powersave/powersave.c and enabling the macro POWERSAVE_STANDALONE_TEST_DEEPSLEEP_ASSOC. As mentioned in the document I should get the current around ~1-2 mA. But I am getting around ~16 mA at least as the lowest. Please find the attached snap-shot FYR. I am attahcing the application file also whatever I am using. I also tried to reduce the becon size by disabling WMM, WPS, enablig only 11b as mentioned in one of the document by cyoress.

Can you please tell me whether I am missing something in the configuration? Do I need to do any other board changes to achieve low numbers?cypress_check.PNG

Thanks

Akash

0 Likes
1 Solution
AxLi_1746341
Level 7
10 comments on KBA 5 comments on KBA First comment on KBA
Level 7

FYI,

It looks like the same issue reported below:

https://community.cypress.com/message/160646#160646

vikr  mentioned that "There is an issue with 6.2 SDK, we are working on the fix".

However, there is no follow up so no fix available yet.

View solution in original post

3 Replies
AxLi_1746341
Level 7
10 comments on KBA 5 comments on KBA First comment on KBA
Level 7

FYI,

It looks like the same issue reported below:

https://community.cypress.com/message/160646#160646

vikr  mentioned that "There is an issue with 6.2 SDK, we are working on the fix".

However, there is no follow up so no fix available yet.

aktac_3789331
Level 2
Level 2

Okay, Thanks for the reply.

Then for the stable number which SDK version do you suggest, I should use ?

And moreover, I feel this is not the same issue with the (CYW43907) powersave test app - verify that it is working as intended . As mentioned in that discussion they are at least  getting ~300 uA for sleep interval. I am not getting the same number in sleep also.

But as you suggested there is some issue with the latest SDK so can I know when will it get fixed. Or it would be great if you can suggest the preferable SDK version.

Thanks

Akash

0 Likes
RaktimR_11
Moderator
Moderator 500 likes received 250 likes received 100 likes received
Moderator

You can roll back to WS 6.0.1 for the moment which can be downloaded from WICED-Studio 6.0.1 Installer (Windows) . We will update the thread once the fix is integrated with the future release.