Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

Not applicable
How do I use the WICED eval board with Linux?
3 Replies
Not applicable
WICED evaluation boards use an FTDI FT2232 USB I/O chip that provides:

  • USB-JTAG functionality
  • USB-UART functionality

The WICED eval board has a custom USB VID/PID, and hence the board is not identified as an FTDI virtual com port by Linux.

To enable the USB-JTAG interface (tested on Ubuntu 10.04), create a file

called /etc/udev/rules.d/67-wiced-JTAG.rules containing the following text:

# udev rules file for WICED USB JTAG interface, to allow use by non super-users

SUBSYSTEM=="usb", ATTR{idVendor}=="0a5c", ATTR{idProduct}=="43fa", GROUP="hwlab", MODE="0666"

To load the USB-UART driver , issue the following command on the command line (this could also be put into a Linux startup routine)

The Serial port will be available on /dev/ttyUSB1 (or possibly a different ttyUSBx interface if other ttyUSB devices are already present)

sudo modprobe ftdi_sio vendor=0x0a5c product=0x43fa

Not applicable

Nice, it works for me (Ubuntu 13.10).

I've added this line in /etc/modules for automatic startup:

     ftdi_sio vendor=0x0a5c product=0x43fa

Tested with minicom (apt-get install minicom). The current user must be in the 'dialout' group:

     minicom -D /dev/ttyUSB1

The default settings are correct (115200N81), press reset on the evaluation board you'll see the Wiced startup messages.

Not applicable

For kernels >= 3.12 the product/vendor arguments to the module won't work.

Do this instead:

echo 0a5c 43fa > /sys/bus/usb-serial/drivers/ftdi_sio/new_id

That works for me on Kubuntu 14.04

Or for something more permanent:

cat /etc/udev/rules.d/90-wiced-driver.rules

ACTION=="add", SUBSYSTEMS=="usb", ATTRS{idVendor}=="0a5c", ATTRS{idProduct}=="43fa", GROUP="users", MODE="0666", RUN+="/lib/udev/wiced"

cat /lib/udev/wiced


/sbin/modprobe ftdi_sio & echo 0a5c 43fa > /sys/bus/usb-serial/drivers/ftdi_sio/new_id

Jason H.