cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

Anonymous
Not applicable

Hi,

getting the error "Could not find appropriate Java Runtime Environment (JRE). WICED JRE requires JRE version 1.6.0 or higher..."

I have this installed:

Microsoft Windows [Version 6.1.7601]

Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\IBM_ADMIN>java -version

java version "1.7.0"

Java(TM) SE Runtime Environment (build pwi3270sr9fp40-20160422_01(SR9 FP40))

IBM J9 VM (build 2.6, JRE 1.7.0 Windows 7 x86-32 20160406_298397 (JIT enabled, A

OT enabled)

J9VM - R26_Java726_SR9_20160406_0949_B298397

JIT  - tr.r11_20160328_114192

GC   - R26_Java726_SR9_20160406_0949_B298397

J9CL - 20160406_298397)

JCL - 20160421_01 based on Oracle jdk7u101-b14

C:\Users\IBM_ADMIN>

Windows 7 Pro, SP1, 64-bit

How can I tell if it's the "32-bit" error described elsewhere or is this an issue with WICED being too particular about the version reported by the secure IBM Java system?

/Greg

0 Likes
3 Replies
Anonymous
Not applicable

I had the same problem. Please install the JRE not the Java SDK. Also, can you try with Oracle JRE?

Anonymous
Not applicable

I believe I do have the JRE installed, and according to company policy I cannot install the Oracle version.

I also tried this on my personal laptop with the Oracle JRE and get the same error. What is it actually looking for?

/Greg

0 Likes
Anonymous
Not applicable

I had the same problem

Started by installing Java SE -- same problem

Then installed Java RE -- and voila! problem solved

I am working with v3.5.2 of WICED