cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

Anonymous
Not applicable

Hi,

I'm using the BCM943362WCD4_EVB with WICED-Studio(WICED-SDK Version: Wiced_006.000.001.0005).

I can't debugging when I received signal SIGTRAP.

Could you tell me how to fix?

1. Make snip.scan-BCM943362WCD4-debug download

2. Run 43xxx_Wi-Fi_Debug_Windows

on Console:

[New Thread -268280318]

Program received signal SIGTRAP, Trace/breakpoint trap.

[Switching to Thread -268280318]

0x0800c63a in _start () at WICED/platform/MCU/STM32F2xx/../../ARM_CM3/crt0_GCC.c:81

81     __asm__( "   ldr r1, =link_stack_end\n"

0 Likes
1 Solution
Zhengbao_Zhang
Moderator
Moderator

Hi  T-mat:

      Did you finish the debug configuration before running the debug process?

On the left window please choose 43xx-Wi-Fi_Debug_Window

1.  run the debugger configuration.

2.  switch to Startup page, add below instruction into the area below Halt option:

add-symbol-file build/eclipse_debug/last_built.elf 0x8000000

3. in the same Startup page,  clear Run Commands area, default is like the phrase "stepi "

4. switch to Common page,  click the "Launch in background "

then run the debug process, thanks.

View solution in original post

1 Reply
Zhengbao_Zhang
Moderator
Moderator

Hi  T-mat:

      Did you finish the debug configuration before running the debug process?

On the left window please choose 43xx-Wi-Fi_Debug_Window

1.  run the debugger configuration.

2.  switch to Startup page, add below instruction into the area below Halt option:

add-symbol-file build/eclipse_debug/last_built.elf 0x8000000

3. in the same Startup page,  clear Run Commands area, default is like the phrase "stepi "

4. switch to Common page,  click the "Launch in background "

then run the debug process, thanks.

View solution in original post