cancel
Showing results for 
Search instead for 
Did you mean: 

Wi-Fi Combo

OlKa_3358896
New Contributor II

Hi. I working on video streaming based on CYW43907 in Soft AP mode. Unfortunately current WICED release does not support 802.11n in Soft AP mode. So i want to know, whether  future releases will support this?

0 Likes
1 Solution
OlKa_3358896
New Contributor II

Problem with 802.11n in AP mode solved. Refer to this link ​my country doesn`t support 802.11n. So when I changed WICED_COUNTRY_CODE to WICED_DEFAULT_COUNTRY_CODE(WICED_COUNTRY_UNITED_STATES) it started work.

View solution in original post

0 Likes
7 Replies
Zhengbao_Zhang
Moderator
Moderator

Hello:

We have a snip which shows ap and sta working concurrently , so only softap mode was already supported .

please take that for a reference.

43xxx_Wi-Fi\apps\snip\apsta

0 Likes
Zhengbao_Zhang
Moderator
Moderator

or you mean we can't support 11n mode , will have a try.

0 Likes
OlKa_3358896
New Contributor II

When CYW43907 was started in Soft AP mode it worked by 802.11g protocol. Speed 54Mb/s is not enough for my application. So I tried to enable 802.11n protocol, but unsuccessfully. I used function wwd_wifi_set_11n_support. It has note: "Currently only STA supported". So I want to know, whether future WICED releases will support 802.11n for Soft AP?

0 Likes
Zhengbao_Zhang
Moderator
Moderator

Hello:

I used to reply to another thread to enable the mcs setting on AP interface,  maybe you can have a try .

please try below modifications:

1.

int set_mcs_rate (int argc, char* argv[])

{

......

    if (argc == 3)

mcsonly = (wiced_bool_t)(atoi( argv[2]));

result = wwd_wifi_set_mcs_rate(WWD_AP_INTERFACE, mcs, mcsonly);

2.

wwd_result_t wwd_wifi_set_mcs_rate( wwd_interface_t interface, int32_t mcs, wiced_bool_t mcsonly )

{

    uint32_t nrate = 0;

    UNUSED_PARAMETER(mcsonly);

    if ( mcs != -1 )

    {

//        nrate |= mcs & NRATE_RATE_MASK;

//        nrate |= NRATE_MCS_INUSE;

//        if ( WICED_TRUE == mcsonly )

//        {

// nrate |= NRATE_OVERRIDE_MCS_ONLY;

// }

                             nrate |= mcs & NRATE_RATE_MASK;

                            nrate |=0x01000000;

3.

you need to start AP firstly , then call the mcs_rate set.

> start_ap test123 wpa2 12345678 11

> set_mcs_rate 5 0

> get_rate

52 Mbps

> set_mcs_rate 0 0

> get_rate

6.5 Mbps

> set_mcs_rate 7 0

> get_rate

65 Mbps

Zhengbao_Zhang
Moderator
Moderator

Last reply is a fixed rate test, we can ignore it .  by the way when I tested the APSTA  today,  I found the AP mode was already in n mode with the rate 65M or 72M when I input get_rate .

OlKa_3358896
New Contributor II

I found out this to. But why my application, doesn`t started at 802.11n mode? Maybe some defines need for this?

0 Likes
OlKa_3358896
New Contributor II

Problem with 802.11n in AP mode solved. Refer to this link ​my country doesn`t support 802.11n. So when I changed WICED_COUNTRY_CODE to WICED_DEFAULT_COUNTRY_CODE(WICED_COUNTRY_UNITED_STATES) it started work.

View solution in original post

0 Likes