Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

USB superspeed peripherals

veRN_2322216
Level 3
5 likes given First like received First like given
Level 3

hello ,

I am trying to Debug the Fx3 Firmware Examples using Segger jlink while Debugging it is Showing Error As Attached Below After Following Steps As per Document (EzUsbSuite_UG_0 .pdf). Can Any One Help Me

Thanks Regards

Veerendra

0 Likes
1 Solution
alamandaa_16
Moderator
Moderator 10 likes received First like received
Moderator

Hello Veerendra,

I retried to Debug the SlaveFifoAsync (FX3 example) firmware using Segger jlink debugger with Windows-10pro.It works fine.

Following are the debug configuration settings.

1.No changes are required under the Main tab.

cap1.PNG

2.On the “Debugger” tab, browse and select the path to the J-Link GDB Server executable, specify “ARM9” as the Device Name and select JTAG as the debug interface.

Capture2.PNG

3.On the “Startup” tab, disable the “Enable flash breakpoints”, “Enable semihosting” and “Pre-run reset and halt".

Capture3.PNG

4.Click on “Apply” to save settings, and then click on “Debug” to start debugging.select Yes to switch to the Debug perspective

Capture4.PNG

5.

Capture5.PNG

Regards,

Anil Srinivas.

View solution in original post

8 Replies
Hemanth
Moderator
Moderator First question asked 750 replies posted 500 replies posted
Moderator

Hi Veerendra,

Is it working in other OS?

Regards,

Hemanth

Hemanth
0 Likes
Anonymous
Not applicable

hi hemanth ,

yes it is working  in other OS

thanks regards

veerendra

0 Likes
alamandaa_16
Moderator
Moderator 10 likes received First like received
Moderator

Hello Veerendra,

--We tried to Debug the Fx3 Firmware Examples using Segger in Windows 10 pro and got above error.

--We are working on this issue and get back to you.

Regards,

Anil Srinivas.

0 Likes
Anonymous
Not applicable

Hello Anil Srinivas,

                                  May i know when this problem will get solve and also please let me know the solution .

regards

Veerendra.

0 Likes
alamandaa_16
Moderator
Moderator 10 likes received First like received
Moderator

Hello Veerndra,

If you are using CYUSB3KIT-001 development kit following items has to be checked before doing the JTAG debug.

1. In the Control center one device should be present as shown in the below image.

Capture22.JPG

2. If Cypress USB Bootloader device is missing - then please check the PMODE pins of FX3 whether it indicates USB Boot. If it is there then please check whether the device is bound to any other driver in the device manager. If yes, then please update the driver to Cypress cyusb3 (which can be found in FX3 SDK).

If the above are fine, Please refer "EzUsbSuite_UG.pdf. chapter 3.1 of the document explain the JTAG debugging steps in detail. Please follow the same and let us know if you are still facing the issue. The document can be found in the FX3 SDK installation directory.

Regards,

Anil Srinivas.

veRN_2322216
Level 3
5 likes given First like received First like given
Level 3

hi Anil Srinivas,

                            I checked All the condition which you mentioned Above  and i followed the steps mentioned in the "EzUsbSuite_UG.pdf. chapter 3.1. even though i am facing the Same problem.

you checkout Control Centers image which i Attached belowCC_Discryptor_info.png

thanks regards

veerendra.

0 Likes
alamandaa_16
Moderator
Moderator 10 likes received First like received
Moderator

Hello Veerendra,

I retried to Debug the SlaveFifoAsync (FX3 example) firmware using Segger jlink debugger with Windows-10pro.It works fine.

Following are the debug configuration settings.

1.No changes are required under the Main tab.

cap1.PNG

2.On the “Debugger” tab, browse and select the path to the J-Link GDB Server executable, specify “ARM9” as the Device Name and select JTAG as the debug interface.

Capture2.PNG

3.On the “Startup” tab, disable the “Enable flash breakpoints”, “Enable semihosting” and “Pre-run reset and halt".

Capture3.PNG

4.Click on “Apply” to save settings, and then click on “Debug” to start debugging.select Yes to switch to the Debug perspective

Capture4.PNG

5.

Capture5.PNG

Regards,

Anil Srinivas.

veRN_2322216
Level 3
5 likes given First like received First like given
Level 3

hello Anil & Hemanth,

                 thank you so much  for giving  your valuable time to my post now its working

thanks regards ,

veerendra

0 Likes