cancel
Showing results for 
Search instead for 
Did you mean: 

USB superspeed peripherals

mbahnsen
New Contributor

Hello, I am working with the CX3 Denebola Dev Kit. I am trying to get the device to enumerate as a USB 3.0 device and it will not. It does not seem to want to connect to my host computer after CyU3PConnectState(CyTrue , CyTrue) is called. I am using FX3 SDK 1.3.4 and the default firmware from e-con systems for this board with the OV5640 imager, along with the default USB cable included with the board. USB 2.0 works just fine and I can stream with the imager when I disable Super Speed or just connect it to a USB 2.0 port. 

0 Likes
1 Solution
Rashi_Vatsa
Moderator
Moderator

Hello,

I understand that the CX3 Denebola doesn't enumerate after the firmware is programmed to the RAM. Is my understanding correct?

To check if the issue is with the firmware or hardware, can you please try using the Usbbulksrcink firmware (Path: )\Cypress\EZ-USB FX3 SDK\1.3\firmware\basic_examples) of FX3 SDK and let me know if the device comes up as USB 3.0 device. If no, please share the UART debug prints for us to check.

Regards,
Rashi

View solution in original post

0 Likes
1 Reply
Rashi_Vatsa
Moderator
Moderator

Hello,

I understand that the CX3 Denebola doesn't enumerate after the firmware is programmed to the RAM. Is my understanding correct?

To check if the issue is with the firmware or hardware, can you please try using the Usbbulksrcink firmware (Path: )\Cypress\EZ-USB FX3 SDK\1.3\firmware\basic_examples) of FX3 SDK and let me know if the device comes up as USB 3.0 device. If no, please share the UART debug prints for us to check.

Regards,
Rashi

View solution in original post

0 Likes