cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

Anonymous
Not applicable

Hi Everybody.

   

 

   

SDK is updated.(SDK v1.3.3)

   

AN65974 Sample is not boot.

   

(SDK v1.3.1 is OK)

   

 

   

Let's me know, What is worng for me.

   

 

   

Best Regards.

   

Jade, Lee

0 Likes
7 Replies
Anonymous
Not applicable

 The firmware does work. However, with the 1.3.3 release of the SDK, it won't compile by default. This is because we're now using an updated version of GCC.

   

 

   

You can go to the project's properties, navigate to C/C++ Build > Build Variables and then add "ARMGCC_VERSION" as a build variable with "4.8.1" as the Value and "String" as the Type.

0 Likes
Anonymous
Not applicable
        Thanks for your replay. But I still have same problem. ARMGCC_VERSION is already set 4.8.1 in System Enviroment Variable. I added build varible with "4.8.1", still have same problem. I will attached test program. This program is same to AN65974(FX3 Firmware). (modify only project name)   
0 Likes
Anonymous
Not applicable

I found the seem problem.

   

In Eclipse show:

   

arm-none-eabi-gcc: C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\/lib/gcc/arm-none-eabi/4.8.1/libgcc.a: No such file or directory

   

cs-make: *** [SlaveFifoSync.elf] Error 1

   

 

   

I found in my pc, there is only one 

   

C:\Program Files (x86)\Cypress\EZ-USB FX3 SDK\1.3\lib\gcc\arm-none-eabi\4.5.2 folder.

   

 

   

How to solve this problem?

0 Likes
Anonymous
Not applicable

I solved this program.

   

I think eclipse project have compiler option & information.

   

App note formware is created 1.3.1 eclipse project, this is my guess.

   

So I create new project width 1.3.3 eclipse.

   

It's working good.

   

 

   

Thanks to people interested. 

   

Have a nice day.

0 Likes
Anonymous
Not applicable

 I have solved the problem too.

   

The download SDK 1.3.3 link is wrong, if you don't download the SDK by the download tool  "Akamai Download Manager (DLM) ",

   

just "download the file without using the download manager", the download file is SDK 1.3.1.

0 Likes
Anonymous
Not applicable

I am having the same problem but I cannot find SDK 1.3.1.

   

 

   

The  "You can go to the project's properties, navigate to C/C++ Build > Build Variables and then add "ARMGCC_VERSION" as a build variable with "4.8.1" as the Value and "String" as the Type." suggestion didn't do anything regarding this problem.

   

What do I do?

0 Likes
user_294846
New Contributor II

try reinstall the SDK in another directory which doesn't include "Program Files (x86)" .

0 Likes