Announcements
IMPORTANT: Cypress Developer Community currently doesn’t allow sign-in to prepare for the upcoming transition. To learn more, check out our announcement.
cancel
Showing results for 
Search instead for 
Did you mean: 

USB Superspeed Peripherals

ajmc_3522501
New Contributor II

Hi,

I am configuring CX3 for a 1851 * 900 resolution with 60 Fps in RAW8 format.

The details are shown in the image below.

The pixel clock needed as per configuration is 100MHz but when i select this in tool it shows up an error even though the entered value and max value are the same.

Could you please help me by confirming whether CX3 would work with a 100MHz pixel clock and the given configuration

pastedImage_19.png

Another problem was when i changed the output data format to 24 Bits.

Now the CSI clock is showing error stating it needs minimum 466Mhz and also the Pixel clock is showing errors.

Correct me if i'm wrong but pixel clock actually needed in this case would be 100/3 = 33.3Mhz. But the tool is not accepting this value.

Could you please verify these configurations.

pastedImage_29.png

Thanks in advance.

0 Likes
1 Solution
abhinavg_21
Moderator
Moderator

Hi,

The first configuration(with RAW8) looks fine to me you can go ahead and configure CX3.

For the second configuration I checked it on the latest CX3 config tool, CSI clock limit as shown by the tool is MIN: 155.52. I am attaching the screenshot of the config tool.

Please update the tool to FX3SDK 1.3.4 and then try.

Thanks & Regards

Abhinav

View solution in original post

1 Reply
abhinavg_21
Moderator
Moderator

Hi,

The first configuration(with RAW8) looks fine to me you can go ahead and configure CX3.

For the second configuration I checked it on the latest CX3 config tool, CSI clock limit as shown by the tool is MIN: 155.52. I am attaching the screenshot of the config tool.

Please update the tool to FX3SDK 1.3.4 and then try.

Thanks & Regards

Abhinav

View solution in original post