cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

BhBh_4156241
New Contributor II

Helloo

I'm working on fx2lp, its working fine for windows xp,windows 7. but it is not working for windows 10?what is the reason for this?

can u plz let me know the installation process of usb  drivers?

Thanks&regards

Bhavya

0 Likes
1 Solution
YatheeshD_36
Moderator
Moderator

Hello Bhavya,

The drivers for the device can be manually updated after the enumeration in the device manager.

Please follow the procedures mentioned below:

1) Select the enumerated device in the device manager to which the driver needs to be updated.

2) Go to properties by double clicking on it

3) Under driver tab select "update driver" ->  Browse my computer for driver software ->  Let me pick from a list of available drivers for my computer -> Have disk -> Browse-> browse to the required driver folder and select the inf file -> Click on Next.

This should install the required driver for your device. Please make sure that the driver are compatible for your application.

Best Regards,

Yatheesh

View solution in original post

0 Likes
9 Replies
YatheeshD_36
Moderator
Moderator

Hello Bhavya,

The drivers for the device can be manually updated after the enumeration in the device manager.

Please follow the procedures mentioned below:

1) Select the enumerated device in the device manager to which the driver needs to be updated.

2) Go to properties by double clicking on it

3) Under driver tab select "update driver" ->  Browse my computer for driver software ->  Let me pick from a list of available drivers for my computer -> Have disk -> Browse-> browse to the required driver folder and select the inf file -> Click on Next.

This should install the required driver for your device. Please make sure that the driver are compatible for your application.

Best Regards,

Yatheesh

View solution in original post

0 Likes
BhBh_4156241
New Contributor II

Helloo Yatheesh

Thanks for your reply

I have follow the steps what you gave,now also it is not showing proper image.I really don't know whats wrong with this?

U can observe clearly in image  which im going to attach in that Im using 1.2.3.20 version.(is it because of this?)

I have attach the image please tell how to overcome from this problem? We are at the final stage of project,now we are facing this problem.

Thanks&regards

Bhavya

0 Likes
YatheeshD_36
Moderator
Moderator

Hello Bhavya,

Is it the same driver version in windows 7 as well?

If its not the same please try the driver version which was used in windows 7 where the image was displaying properly.

Can you please let me know which host application you are using for displaying the image. Can you please attach the host application here.

Best Regards,

Yatheesh

0 Likes
BhBh_4156241
New Contributor II

Hello Yatheesh

The same drivers I'm using in windows 7 and  windows 10.

Can you please let me know which host application you are using for displaying the image?

~> I'm using the GUI application to display the image.

Thanks&regard

Bhavya

0 Likes
YatheeshD_36
Moderator
Moderator

Hello Bhavya,

In the function Receive_data() in the application, the bulkEptINdata.XferData() should take in only 2 arguments, please remove the third parameter. Also please read the return value from the bulkEptINdata.XferData() and check if its returning true. Please specify a timeout value for the same.

For another method of debugging, you can capture the RAW data from the FX2LP device using the CyControl center where you can send the required control commands through the control end point and do a bulk IN transfer from the bulk loop end point and check if the data received is proper by converting it into an image.

Thanks,

Yatheesh

0 Likes
BhBh_4156241
New Contributor II

Hello Yatheesh

Receive_data() in the application, the bulkEptINdata.XferData() should take in only 2 arguments-> Changed this

check if its returning true->Yes

For another method of debugging, you can capture the RAW data from the FX2LP device using the CyControl center where you can send the required control commands through the control end point and do a bulk IN transfer from the bulk loop end point and check if the data received is proper by converting it into an image.-> from the control center end point im getting data continuously.

After doing the correction also the problem is not solved it is showing the same distorted image only.can u give any other solution for this?

Regards&Thanks

Bhavya

0 Likes
YatheeshD_36
Moderator
Moderator

Hello Bhavya,

Did you check if you are getting a timeout error.

Also please specify a time out value to the endpoint.

Best Regards,

Yatheesh

0 Likes
BhBh_4156241
New Contributor II

Hello Yatheesh

Thanks for your rly

How to check the timeout error here?

I'm specifying the time out in GUI i.e CyControlEnd.TimeOut = 2000;

Thanks &regard

Bhavya

0 Likes
YatheeshD_36
Moderator
Moderator

Hello Bhavya,

The XferData returns False if the transaction did not complete within the timeout. You can check the return value from the XferData function and print a debug message.

Thanks

Yatheesh

0 Likes