cancel
Showing results for 
Search instead for 
Did you mean: 

USB Low-Full-High Speed Peripherals

Anonymous
Not applicable

Hi, i've a solar inverter with Cypress USB to Serial controller VID 0665 PID 5161. I'm trying to using this serial port with Linux. Windows system found the serial controller las an input device (HID). I tried to install the diver manually but did not change. I read on the forum that to modify the controller I had to use CypressSerialConfigurationUtility but when i open the utility obviously it does not find any controllers because the drivers can not be installed and windows keeps seeing the controller as an input device. How can I convert this "input device" into a simple serial COM port? Thanks !

0 Likes
1 Solution
YangyangC_06
Employee

Hi lol lol,

As I said before, Cypress's VID is 0x04B4. In addition, the USB-serial product will not enumerate as a HID device.

You will not see USB-serial enumerating as HID device no matter what you configure SCB0 and SCB1.

Because we set

    0x00,                           /* Device class */

    0x00,                           /* Device sub-class */

    0x00,                           /* Device protocol */

BaiduShurufa_2018-3-29_14-7-28.bmp

in the firmware which doesn't mean a HID device. In addition, we don't release the source code of firmware to customer.

Based on the reasons above, I suspect you must make something wrong.

View solution in original post

0 Likes
3 Replies
Anonymous
Not applicable

Hi,

Please right click the device, uninstall the driver, before updating a new one.

Regards,

- Madhu Sudhan

0 Likes
Anonymous
Not applicable

Hi, thanks for the reply. I've already tried to uninstall the hid input device and manually install the driver using your .inf file but windows keeps saying that the driver is not correct.

0 Likes
YangyangC_06
Employee

Hi lol lol,

As I said before, Cypress's VID is 0x04B4. In addition, the USB-serial product will not enumerate as a HID device.

You will not see USB-serial enumerating as HID device no matter what you configure SCB0 and SCB1.

Because we set

    0x00,                           /* Device class */

    0x00,                           /* Device sub-class */

    0x00,                           /* Device protocol */

BaiduShurufa_2018-3-29_14-7-28.bmp

in the firmware which doesn't mean a HID device. In addition, we don't release the source code of firmware to customer.

Based on the reasons above, I suspect you must make something wrong.

View solution in original post

0 Likes