cancel
Showing results for 
Search instead for 
Did you mean: 

TRAVEO™ T2G

dej_4749716
New Contributor

Hi,

   Currently I am involved in writing the code for the implementation of UART operation over the LIN module of Traveo™ II Automotive Body Controller.

I configured the LIN registers as below.

The LIN block supports limited UART functionality:

■ Programmable 5/6/7/8-bit data fields (CTL0i.BREAK_DELIMITER_LENGTH[1:0]).

■ Programmable number of STOP bits:  1, bit (CTL0i.STOP_BITS[1:0]).

■ Optional parity functionality (CTL0i.PARITY_EN) with odd and even parity (CTL0i.PARITY).

The UART operation mode is enabled, when CTL0i.MODE is set to '1'.

after this configuration I created a transmit buffer to send few bytes of data over the LIN bus, but my transmission is not successful.

Could you please confirm if I missed any configuration to be set for the UART mode operation

Regards,

Devakumar J

0 Likes
1 Solution
TakashiM_61
Moderator
Moderator

Dear Devakumar J,

Thank you very much for your posting query in CDC.

However, TVII topic still cannot be handled in public space, i.e CDC.

So could you please contact Cypress (An Infineon Technologies Company)  sales representative for this topic?

It would be appreciated if you comprehend for this.

regards.

View solution in original post

0 Likes
1 Reply
TakashiM_61
Moderator
Moderator

Dear Devakumar J,

Thank you very much for your posting query in CDC.

However, TVII topic still cannot be handled in public space, i.e CDC.

So could you please contact Cypress (An Infineon Technologies Company)  sales representative for this topic?

It would be appreciated if you comprehend for this.

regards.

View solution in original post

0 Likes