cancel
Showing results for 
Search instead for 
Did you mean: 

Studio Bluetooth

БахманерНурназа
New Contributor

Hello Cypress Community! I have some problems with low power application. I use CYW90719Q40EVB-01.
Here I will explain it in few steps:

1. I generated a BLE application ("T-Shirt") using WICED Bluetooth Designer.
2. Edited the source code according to "low_power_sensor" demo of WICED Studio
3. I run it.
4. When timeout occurs, It successfully goes to sleep.

But when it starts sleeping, it accidentaly wakes up again, although I don't call interrupts.
My question is WHAT CAN BE THE CAUSE? WHO HAD SUCH PROBLEM, PLESE HELP!

P.S. I have attached the source code just in case...

Best regards,
Bakhman.

0 Likes
1 Solution
БахманерНурназа
New Contributor

Thanks for your interest OwenZ_26 !


Even when i disabled all advertisements the behaviour was the same.

But fortunately I found the problem. I should have changed the value of "Interval of random address refreshing" in "wiced_bt_cfg.c"

/* LE Address Resolution Database Settings */

from

         .rpa_refresh_timeout = WICED_BT_CFG_DEFAULT_RANDOM_ADDRESS_CHANGE_TIMEOUT,

to

         .rpa_refresh_timeout = WICED_BT_CFG_DEFAULT_RANDOM_ADDRESS_NEVER_CHANGE,

This parameter made the application wake up again and again!

View solution in original post

3 Replies
Owen_Zhang123
Moderator
Moderator

The device can wake up by bluetooth activity. Did you check if it is a bluetooth event such as advertisement wakes up the device?

You may refer to this artical for details: https://www.cypress.com/file/415986/download

БахманерНурназа
New Contributor

Thanks for your interest OwenZ_26 !


Even when i disabled all advertisements the behaviour was the same.

But fortunately I found the problem. I should have changed the value of "Interval of random address refreshing" in "wiced_bt_cfg.c"

/* LE Address Resolution Database Settings */

from

         .rpa_refresh_timeout = WICED_BT_CFG_DEFAULT_RANDOM_ADDRESS_CHANGE_TIMEOUT,

to

         .rpa_refresh_timeout = WICED_BT_CFG_DEFAULT_RANDOM_ADDRESS_NEVER_CHANGE,

This parameter made the application wake up again and again!

View solution in original post

Owen_Zhang123
Moderator
Moderator

Thanks for sharing the resolution with the community@Бахманер Нурназаров