cancel
Showing results for 
Search instead for 
Did you mean: 

Studio Bluetooth

ToWa_1311181
New Contributor II

Hi,

  I follow the content of "CYW920719Q40EVB-01 Evaluation Board User Guide.pdf" on page 17 to "Make Target" of "demo.hello_sensor-CYW920719Q40EVB_01 download". It's fail even I used the combination of the "Recovery" and "Reset" buttons on board. My computer is HP Pavilion 590-P0086 desktop computer runninh Windows 10.

Please refer to the screen capture of the image attached, it's shown the COM port detection, the TeraTerm display and the message of the Wiced screens. The other image is the jumper setting of the hardware, as the original setting from you and matched with the jumper requirement from your document.

If possible, please give some comment if I could send some command to HCI to verify the unit. By the way, the echo message on the TeraTerm screen is during the regular boot up. If using the "Recovery"/"Reset" buttons, that screen is no any information popped up.

Regards,

Tony

0 Likes
1 Solution
SheetalJ
Moderator
Moderator

Hi Tony,

In Device Manager, you will be seeing two COM ports when you connect the device to your PC/laptop. Usually lower number COM port is HCI UART and higher number COM port is PUART.

For seeing logs on Teraterm, you have to open PUART in Teraterm. Do not open HCI UART anywhere when you are programming the device. The make target you are using is correct.

Just to be sure, you can add COM port to make target, for example, demo.hello_sensor-CYW920719Q40EVB_01 download UART=COM21

(COM21 is HCI UART here)

Now program the board after recovering it, you should see the logs on Teraterm and device should advertise itself (I assume you are downloading hello sensor app).

View solution in original post

2 Replies
SheetalJ
Moderator
Moderator

Hi Tony,

In Device Manager, you will be seeing two COM ports when you connect the device to your PC/laptop. Usually lower number COM port is HCI UART and higher number COM port is PUART.

For seeing logs on Teraterm, you have to open PUART in Teraterm. Do not open HCI UART anywhere when you are programming the device. The make target you are using is correct.

Just to be sure, you can add COM port to make target, for example, demo.hello_sensor-CYW920719Q40EVB_01 download UART=COM21

(COM21 is HCI UART here)

Now program the board after recovering it, you should see the logs on Teraterm and device should advertise itself (I assume you are downloading hello sensor app).

View solution in original post

ToWa_1311181
New Contributor II

Hi,

  Thanks for help to address this issue. According to your instruction, I close the COM port window that used for the HCI interface. The problem is resolved.

Regards,

Tony