cancel
Showing results for 
Search instead for 
Did you mean: 

Studio Bluetooth

GHKC
New Contributor

i need to load program from cyw20706 kit to cybt-343026 board.

when i was trying to load it is given error like detection failure.

can i get help regardintg this problem

regards

harikrishna g

0 Likes
1 Solution
AnjanaM_61
Moderator
Moderator

Hi HaGo_4718696 ,

Ok. Then please go through the programming links provided above.  Please confirm if you are just using 343026 module or EVAL.

Make sure you have copied the platform files as I mentioned in above response.

Then please check if HCI UART and PUART is getting enabled or not. HCI UART (with low com port number) is the one you have use for programming the module.

Do recovery steps as mentioned in the Programming an EZ-BT WICED Module – KBA223428

If still getting error , include the COM port in make target . Example demo.hello_sensor-CYBT_343026_EVAL download UART=COMxx where xx is your HCI UART com port

Thanks & Regards,

Anjana

View solution in original post

5 Replies
AnjanaM_61
Moderator
Moderator

Hi HaGo_4718696 ,

You mean you are connecting HCI UART lines of 20706 EVAL kit with HCI UART pins of 343026 module ? Please clarify ?

If you are using 343026 EVAL ( https://www.cypress.com/documentation/development-kitsboards/cybt-343026-eval-ez-bt-module-arduino-e...  ) then you can directly download the program . Please clarify your query.

- Make sure your connections are correct

- Make sure you are using platform files available here: https://community.cypress.com/docs/DOC-13750

- Please go the blog for programming related doubts : Programming an EZ-BT WICED Module – KBA223428

- You can also use programming GUI available here: WICED Module Programmer User Guide – KBA225060

- Reference : getting started appnote - https://www.cypress.com/documentation/application-notes/an223400-getting-started-ez-bt-wiced-modules

Thanks & Regards,

Anjana

GHKC
New Contributor

connection i given from HCI UART pins(J26) of 20706 EVAL kit to  HCI UART pins of 343026 module

all connections are correct .

0 Likes
AnjanaM_61
Moderator
Moderator

Hi HaGo_4718696 ,

Ok. Then please go through the programming links provided above.  Please confirm if you are just using 343026 module or EVAL.

Make sure you have copied the platform files as I mentioned in above response.

Then please check if HCI UART and PUART is getting enabled or not. HCI UART (with low com port number) is the one you have use for programming the module.

Do recovery steps as mentioned in the Programming an EZ-BT WICED Module – KBA223428

If still getting error , include the COM port in make target . Example demo.hello_sensor-CYBT_343026_EVAL download UART=COMxx where xx is your HCI UART com port

Thanks & Regards,

Anjana

View solution in original post

GHKC
New Contributor

thanks for your help and immediate madam.

after recover the module it is detected and downloaded.

but after loading firmware module not advertising i checked on 3 modules(CYBT-343026) by loading spp program and hello_sensor program.

for this issue can you provide any solution.

0 Likes
AnjanaM_61
Moderator
Moderator

Hi HaGo_4718696 ,

Glad to know that you were able to download the application Successfully.

I noticed you opened new thread for advertising : CYBT-343026 Module not advertising We shall resolve this issue in that thread.

Please make sure you have included the platform files for 343026 : Platform Files for CYBT-343026-EVAL – KBA221025  If you are not using the platform files, you may face issues in the application.

Thanks & Regards,

Anjana