cancel
Showing results for 
Search instead for 
Did you mean: 

Studio Bluetooth

sape_4812941
New Contributor II
 

Hi, I am working with the CYW4343 and am trying to connect via bluetooth and access GATT services. I tested the different projects available in Wiced like (simple_ble_peripheral and wifi_introducer) everything works fine with IOS and Androit as a client. The problem occurs when I use Windows 10 as a client. Once  connected, getting services is very slow and unstable. Even the pairing sequence is not really stable. I notice that on some request, the device goes on hold and seems to be reaching timeouts. Is it possible to have a sample project tested under windows 10 which contains GATT services. Otherwise someone able to help us with the parameters of the Ble stack that could be causing these problems. I include as attachments a picture of the output log of a IOS connection and read for the Wifi_introducer project and a output as a  widows 10 Client. 

 

Log_IOS_Connect_read.png

Log_win_Connect.png

 

 

0 Likes
1 Solution
Charles_Lai
Moderator
Moderator

Hi,

To avoid unexpected bugs, please use the CySmart tool and the CY5677 CySmart BLE 4.2 USB Dongle, to debug your BLE application and GATT services. See below:
https://www.cypress.com/documentation/software-and-drivers/cysmart-bluetooth-le-test-and-debug-tool

And you can also try another USB Bluetooth LE module (besides the built-in module of your computer), with your current test environment, to see if the original Bluetooth LE module was malfunctioning.

Best regards

View solution in original post

0 Likes
1 Reply