cancel
Showing results for 
Search instead for 
Did you mean: 

Studio Bluetooth

PrU_4445086
New Contributor

Hi
We are working on a product which uses the CYBT-343026-01 module from cypress which supports BT + BLE coexistence.

Our use case involve using Classic Bluetooth connection with A2DP profile for audio streaming from mobile app to our device , BLE peripheral having some services and characteristics for data exchange between Mobile BLE App and our device and BLE scanner for scanning Non Connectable data packets(Beacon Data) from another BLE accessory.

We are able to establish the audio streaming with the Mobile phone and also connect to the BLE App on the mobile phone and interact with the App while the audio is playing without any packet loss.
Hence BLE services and Classic bluetooth as media device for audio streaming is visible in smartphone and able to connect smartphone to the device for both BLE and Classic bluetooth.However, the issue we see is that our device is not able to receive any Beacon data when audio streaming is going on and when audio streaming is paused the beacon data is received by our device.We also tried to stop the ble advertisement when a2dp streaming is on to solve this issue but didn't see any difference.

How can we ensure the chip receive the BLE beacon data while audio streaming is active ? Is there any additional command or state that needs to be set for the chip to function in this condition.

0 Likes
1 Solution
AnjanaM_61
Moderator
Moderator

Hi PrU_4445086 ,

Sorry for keeping you wait.
Seems like this is a limitation on our chip. You have to pause the streaming to get BLE scan working.

If this is a critical requirement , I would suggest you to contact our local FAE for evaluating the feature request.

Thanks & Regards,

Anjana

View solution in original post

0 Likes
4 Replies
AnjanaM_61
Moderator
Moderator

Hi PrU_4445086 ,

Do you mean , BLE connection is working fine along with Audio streaming , however some adv packets are missing ?

Can you please clarify how many BT roles you are using ? Are you using one BT A2DP + one BLE or BT A2DP + BLE connection +BLE beacon? Please clarify the scenario.

Did you try changing the advertising time interval and see if it works?

If possible , please share your project and steps to reproduce the issue at our side.

Thanks & Regards,

Anjana

0 Likes
PrU_4445086
New Contributor

Hi AnjanaM_61,

Please find the inline response for your queries.

Do you mean , BLE connection is working fine along with Audio

streaming, however

some adv packets are missing ?

:Yes BLE Connection is working fine along with Audio streaming.No

advertising packets are being missed. The problem is that the

CYBT-343026-01 is not able to

receive any scan packets (non connectable or connectable) when audio

streaming is on and when audio streaming is paused the scan packets

are being received and I can view it in debug log.

Can you please clarify how many BT roles you are using ? Are you using one

BT A2DP + one BLE or BT A2DP + BLE connection +BLE beacon?

We are using BT A2DP + BLE Connection (Peripheral) + BLE Beacon

scanner for our use case

Did you try changing the advertising time interval and see if it works?

No. Does advertising time interval have any impact on scanning?

Regards,

Preethi

On Wed, Aug 26, 2020 at 10:53 AM AnjanaM_61 <community-manager@cypress.com>

0 Likes
AnjanaM_61
Moderator
Moderator

Hi PrU_4445086 ,

I am sorry, initially I confused with the description. I thought you are facing issues with A2DP stream + BLE adv.

I understood the issue is with A2DP stream + BLE Scan. The parameters effecting scan is the scan interval , window & timeout under ble_scan_cfg

I was able to reproduce your issue. I am checking internally with our FW team if there is any work around available for the same.

Regards,

Anjana

0 Likes
AnjanaM_61
Moderator
Moderator

Hi PrU_4445086 ,

Sorry for keeping you wait.
Seems like this is a limitation on our chip. You have to pause the streaming to get BLE scan working.

If this is a critical requirement , I would suggest you to contact our local FAE for evaluating the feature request.

Thanks & Regards,

Anjana

View solution in original post

0 Likes