cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Bluetooth

Anonymous
Not applicable

Hi,

after compile the hello_sensor example in eclipse, I get the following erros:

Field 'adrType' could not be resolved    hello_sensor.c    /WICED-Smart-SDK/Apps/hello_sensor    line 588    Semantic Error

Symbol 'lesmp_pinfo' could not be resolved    hello_sensor.c    /WICED-Smart-SDK/Apps/hello_sensor    line 588    Semantic Error

Field 'lesmpkeys_bondedInfo' could not be resolved    hello_sensor.c    /WICED-Smart-SDK/Apps/hello_sensor    line 588    Semantic Error

Field 'pairingParam' could not be resolved    hello_sensor.c    /WICED-Smart-SDK/Apps/hello_sensor    line 499    Semantic Error

Field 'AuthReq' could not be resolved    hello_sensor.c    /WICED-Smart-SDK/Apps/hello_sensor    line 499    Semantic Error

Symbol 'lesmp_pinfo' could not be resolved    hello_sensor.c    /WICED-Smart-SDK/Apps/hello_sensor    line 499    Semantic Error

But the fashing to the board is possible. But how can I resolve the errors?

Best regards and thanks for you help.

Christoph

0 Likes
1 Solution
MichaelF_56
Moderator
Moderator

I believe this thread addresses your concern and shows you how to turn off the error messages within Eclipse: Eclipse IDE compilation errors

vik86

View solution in original post

0 Likes
7 Replies
MichaelF_56
Moderator
Moderator

Which version of the SDK are you using?

Windows? Mac?

Which HW platform, the TAG3 development board?

If no, does the default hello_sensor program compile and run on the TAG3 development board when using SDK 2.x?

Are you double-clicking on the make file iteself to compile and run, or are you trying to use the menus within the IDE to do the same (menus do not work for compile and run)?

What does this mean? "But the fashing to the board is possible"

Starting with a known good setup, then adding customizations to the sample programs is the best way to troubleshoot an issue like this one if it ends up being syntax issues within the code itself.

Anonymous
Not applicable

Version of SDK 2.1 on Windows

HW platform BCW920737TAG dev-board

I don't modify the hello_sensor-code. I using the menu "make target" and then "build target". The build process and the download to the dev-board are successful.

But eclipse says that are six errors (see above). Why?

0 Likes
MichaelF_56
Moderator
Moderator

Use the item in the Make Target window to compile and run.

make-target.png

Anonymous
Not applicable

Thank you, but I do it like your screenshot.

The result is: Compilation is fine and donwload to the device successful!!!

But: But Eclipse show some erros. The the screenshots below.

pastedImage_1.png

pastedImage_0.png

0 Likes
MichaelF_56
Moderator
Moderator

I believe this thread addresses your concern and shows you how to turn off the error messages within Eclipse: Eclipse IDE compilation errors

vik86

View solution in original post

0 Likes
Anonymous
Not applicable

Which thread do you mean? (There is no link, only to vik86-profile) Thanks.

0 Likes
MichaelF_56
Moderator
Moderator

My apologies.  I've since added the link.

0 Likes