cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Bluetooth

Anonymous
Not applicable

Hello,

  We're in production for a product that uses the BCM20737. The board is very basic, only the BCM20737 module, accelerometer, and an LED. Most are working fine, but about 5% of them are not passing our tests. To narrow down the problem, we loaded on the Broadcom Hello Client example. We discovered that the bad boards are not generating the 1000mSec hello client timeout. See summary below:

This is very hardware specific: good boards will pass repeatedly but the bad boards won't. What could be causing this issue?

Thanks,

Derek

I loaded the Broadcom Hello Client demo application on both good and bad boards.  They output identical logs until the timeouts occurred:

Blue debug -- common logs
Red debug -- did not occur on bad boards

...
GPIOBTN1:OFF=1,INT:0
GPIO_LED:OFF=1
GPIOBAT
GPIO_BUZ:OFF=0
Fine Timer(1000 ms, 1/sec)
Fine TImer tick 80
Normal Timer(1 s, 80 tick)
blecen_connDown[5:2]: 00 00 00 00
blecen_connDown[1:0]: 00 00, handle: 0000
ScanOn
BLE_high_scan:timer(1)
ScanTimer stopped: 1
NoScan
BLE_high_un_adv:timer(1)
TimersKilled
Fine Timer(1000 ms, 1/sec)
Fine TImer tick 80
Normal Timer(0 s, 0 tick)
hello_client_timeout:1
hello_client_timeout:2
hello_client_timeout:3
hello_client_timeout:4
hello_client_timeout:5
hello_client_timeout:6
hello_client_timeout:7
hello_client_timeout:8

...

The bad devices were not dead, either; we still saw interrupts being fired (in the log outputs) from the accelerometer when I shook them, even though the 1000ms timeouts were not.

0 Likes
1 Reply
Anonymous
Not applicable

Hello Derek,

Let us look into this and get back to you.

Thanks,

JT

0 Likes