cancel
Showing results for 
Search instead for 
Did you mean: 

Smart Bluetooth

NiVa_4337911
New Contributor II

Hi,

What is the default firmware in CyBLE013025 modules? I got the following message while booting but I couldn't find anything for the messages starting with "@$"

@$*#04FF16F7009201020000074A057EEA5ECC00074E05D3160000

CYBLE-013025-00 manual says, the device is "Pre-programmed EZ-Serial firmware platform to allow for easy-to-use out of the box Bluetooth Low Energy connectivity", but it is not behaving like EZ serial.

0 Likes
1 Solution
NiVa_4337911
New Contributor II

Thank you, The problem was I selected a different UART (HCI UART) instead of PUART, i.e. SW1 switches 5, and 6 was on instead of 1, and 2.

View solution in original post

0 Likes
4 Replies
Owen_Zhang123
Moderator
Moderator

The default firmware in CYBLE-013025 is EZ-Serial: https://www.cypress.com/documentation/software-and-drivers/ez-serial-ez-ble-module-firmware-platform

Could you check if you set the UART right on your computer, which should be 115200 baud, 8 data bits, no parity, 1 stop bit, flow control disabled.

You may refer to the user guide chapter 2.2 for details: https://www.cypress.com/file/408286/download

NiVa_4337911
New Contributor II

Yes, the UART baud settings are correct. If it is EZSerial it should send @E not @$. And it is only wotking UART TX (module RX) unconnected.

0 Likes
Owen_Zhang123
Moderator
Moderator

The CYBLE-013025 only supports binary mode and doesn't support text mode with puart. You should set your UART to hex mode to receive the binary log or use a python script (refer to the user guide chapter 12) to see the text log.

0 Likes
NiVa_4337911
New Contributor II

Thank you, The problem was I selected a different UART (HCI UART) instead of PUART, i.e. SW1 switches 5, and 6 was on instead of 1, and 2.

View solution in original post

0 Likes