Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

Smart Bluetooth

Anonymous
Not applicable

I'm using the ota_firmware_upgrade example code in WICED ide. I had to modify the target from BCM920737TAG_Q32 to the CYBLE_013025_EVAL target. This meant that I had to also change the GPIO_PIN_WP pin to -1 according to the platform.h file, but I am not sure if that is supposed to stay that way.

I compile the code, install, and see that it shows up on the Andriod WICED app. I then use the WsOtaUpgrade program provided in the peerapps folder, which notify's that it needs to upgrade because this project was made for compilers from 2012. I run the app in debug with a custom command input of the bin file, it launches, I confirm that the HELLO app is connected on ble, and I press start, and it does nothing. After stepping through the debugger, I see that it quits on line 406 of Win8Interface.ccp

hr = pSetDescr(hService, &m_descrClientConfig, &DescriptorValue, BLUETOOTH_GATT_FLAG_NONE);

where it times out.

I went onto the firmware of the chip and found that the hello_sensor_write_handler doesn't ever get used in the start process attempt.

How am I supposed to get this example code to work? It is something that I will need to be able to do if I am going to try and port it over into some of my other code.

Thanks.

0 Likes
1 Solution
Anonymous
Not applicable

Hi Tyler,

I tested the ota_firmware_upgrade project in WICED Smart 2.2 and it worked fine. I was successfully able to update the firmware using the WsOtaUpgrade app that is included in the SDK on a Windows 8 PC.

I had to make just one change in the hello_sensor.c file. The battery and buzzer pins were not defined, so changed their values to -1.

I didn't receive any prompt for upgrading the app. Can you post a snip of the prompt that you are receiving?

View solution in original post

2 Replies