cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ Creator & Designer

AlBa_4283631
New Contributor

I have a PSoC 62 program developed using Creator 4.2 in Windows 7. When I installed PSoC Creator in Windows 10 and attempted to compile the program, I received error messages: "The Peripheral Driver Library (PDL) driver is incompatible with the Scan_ADC_v3_10 (and other components) used in the design, please install the latest PDL." My PDL folders are current through ver 3.1.0. To be sure, I did a "complete" reinstall of PDL 3.1.0 and reinstalled Creator 4.2 - several times. Can anyone help?

Thanks,

Al

0 Likes
1 Solution
DheerajK_81
Moderator
Moderator

Please right click on your project and go to Build Settings > Peripheral Driver Library and check what version is being used by PSoC Creator as shown below:

pastedImage_0.png

If it is not 3.1.0, you can point to it by using the Custom option. Let me know if you are seeing this error even though you have the right option here.


Regards,
Dheeraj

View solution in original post

2 Replies