Showing results for 
Search instead for 
Did you mean: 

PSoC™ Creator & Designer

New Contributor II

A few days ago, PSoC Creator 4.1 closed without warning. When I tried opening it again, an installation window appeared with the following text: "Please wait while Windows configures PSoC Creator". But it ends in error: "Error writing to file: C:\Program Giles (x86)\Cypress\PSoC Creator\4.2\PSoC Creator\bin\psoc_creator.exe. Verify that you have access to that directory." Then I have to cancel the "installation" and I can't open PSoC Creator.

I changed the permissions of that file so every application has total control, and that seemed to solve the issue.

Then I installed PSoC Creator 4.2 to use my kit 149, but the same thing happens when I use some features of the CapSense block (the only one I'm using right now). It closes and I can't open it again. Changing permissions does not solve the issue now.

What is failing? What can I do?



2 Replies

Are you installing the creator with ADMIN rights.

Note Do NOT plug in your Miniprog3 until all software installation is complete AND the PSoC Creator application has been opened.

New Contributor II

I'm experiencing exactly the same problem, which is dragging at least from Creator 4.0, according to similar crash reports in this forum. I also have Windows 10, latest update, and Visual Studio 2017 in the same machine. A rather common scenario I guess. I tried the repair tips suggested in a couple of posts without any success. Also noticed the following.

1) If I load Creator alone, side by side with Visual Studio, I can leave both  running overnight without crashing.

2) If I load a sample project without major modifications, it seems to hold on without crashing.

3) As long as my project works in complexity and move over to Visual Studio to test some piece of code, Creator silently quits without warning or saving edited files or the environment. You loose everything.

4) It seems that one thing that triggers this is when I try to add the printf() over a UART, which I have to remove anyway because in a 32KB Flash 42xxx device consumes all remaining Flash and it can't compile.