cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ Creator & Designer

Anonymous
Not applicable

It looks like when I go into debug, the EEPROM is cleared.

This doesn't happen if I just program the part.

Is there a setting for DEBUG to not clear the eeprom contents?

Thanks.

0 Likes
1 Solution
Bob_Marlowe
Expert II

In Creator you find in workspace explorer settings for the EEProm.

You have set all EEProm area to 0x00 and checked "Include EEProm Data into Hex file". This will -as I understand- let Creator overwrite your EEProm area with zero (0) values.

The settings for Cypress Programmer are different.

Bob

View solution in original post

0 Likes
7 Replies
Bob_Marlowe
Expert II

The EEProm is not cleared when entering debug mode. The situation you see must have a different cause.

Post your complete project or a shortened version that shows the error so that we all can have a look at all of your settings. To do so, use

Creator->File->Create Workspace Bundle (minimal)

and attach the resulting file.

Bob

0 Likes
Anonymous
Not applicable

Bob:

Attached is the project. It was a test project to make sure I understood how this worked before incorporating it.

There is a variable dontwrite that manages when I want it to write to eeprom.

If you do Debug, then the values for readrow will be 0's.

But the same variable using Debug without programming will have the values that is in E2.

The same is true if I just program the part and run Debug without programming.

Appreciate your time.

Giri

0 Likes
Anonymous
Not applicable

sorry I added the Project archive instead of the workspace archive.

here is the workspace archive.

0 Likes
NoriakiT_91
Employee

PSoC Programmer has a "Programmer Options" dialogue invoked by the menu item "Options->Programmer Options"

GS003195.png

There is a radio button in the Clear EEPROM category box.  I don't know how to specify this options from the PSoC Creator.

Does anybody know?

0 Likes
Anonymous
Not applicable

The problem does not exist when you program the part, only when you go into Debug(with programming).

0 Likes
Bob_Marlowe
Expert II

In Creator you find in workspace explorer settings for the EEProm.

You have set all EEProm area to 0x00 and checked "Include EEProm Data into Hex file". This will -as I understand- let Creator overwrite your EEProm area with zero (0) values.

The settings for Cypress Programmer are different.

Bob

View solution in original post

0 Likes
Anonymous
Not applicable

Thank you. That was the magic setting I could not find.

giri

0 Likes