cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ Creator & Designer

DmRu_4683001
New Contributor

No data on UART at all (code is screen-copied). Are any .txt sources available for this sample?

Downloaded sample "UART-printf01" works ok.

0 Likes
1 Solution
Aashita_Raj
Moderator
Moderator

Hi DmRu_4683001​,

I think as you have referred the video, you might have missed something. I have shared the link for the pdf of the video that is, PSoC 6 101- Lesson 3-5a Basic Motion Sensor Implementation : https://iotexpert.com/2018/02/06/bosch-bmi160-psoc-6-cy8ckit-028-epd/ .

Please go through it once and let us know if the issue persists.

I have also attached the text file, which describes the method to enable printf through UART in PSoC 6. You can refer it.

Thanks and Regards,

Aashita

View solution in original post

0 Likes
3 Replies
Aashita_Raj
Moderator
Moderator

Hi DmRu_4683001​,

I think as you have referred the video, you might have missed something. I have shared the link for the pdf of the video that is, PSoC 6 101- Lesson 3-5a Basic Motion Sensor Implementation : https://iotexpert.com/2018/02/06/bosch-bmi160-psoc-6-cy8ckit-028-epd/ .

Please go through it once and let us know if the issue persists.

I have also attached the text file, which describes the method to enable printf through UART in PSoC 6. You can refer it.

Thanks and Regards,

Aashita

View solution in original post

0 Likes
DmRu_4683001
New Contributor

Thank you for the link. Still result is the same - no UART output. (WICED UART projects work ok).

Should there be any changes made as my board is CY8CKIT-062-WiFi-BT not CY8CKIT-028-EPD?

Thank you

0 Likes
Aashita_Raj
Moderator
Moderator

Hello DmRu_4683001​,

I am attaching the project, which shows how to make a complete test system using PSoC 6, interface with BMI160 . This project is an exact implementation of the blog (link shared)- https://iotexpert.com/2018/02/06/bosch-bmi160-psoc-6-cy8ckit-028-epd/  . Please note that the sensor is on the TFT Display Shield Board and not on the PSoC 6 board. The display screen needs to be connected to the kit. Also, please check the pins assigned for I2C based on the shield kit you are using.

Please go through the project and let us know if you are facing the issue again.

Best Regards,

Aashita