cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6

vivec_4189616
New Contributor

I am facing a problem while programming my PSOC6 BLE Pioneer Kit board. I am using Modus Toolbox to program and i have also updated the firmware to Kitprog3 using 'fw-loader' .

I have also attached the screenshot.

Untitled.jpg

0 Likes
1 Solution
DheerajK_81
Moderator
Moderator

You aren't getting the silicon revision because you are using the old version (probably 3.27) of PSoC Programmer. Please use PSoC Programmer 3.28 . But since the board revision is 11 as you mentioned, it is an old revision and it will not work with ModusToolbox as seen from the table.

You will need a replacement kit and Cypress will be contacting you shortly.

Regards,

Dheeraj

View solution in original post

0 Likes
4 Replies
DheerajK_81
Moderator
Moderator

Please use PSoC Programmer 3.28​ and determine the Silicon Revision by using the EraseAll option as shown below:

product_page_2.PNG

Also, check the back of the kit for the label which mentions the Board revision.

Check if it compatible with ModusToolbox based on the combination you have according to the following table:

product_page.PNG

Regards,

Dheeraj

vivec_4189616
New Contributor

pastedImage_0.png

I didn't get the KIT revision through programmer.

But behind my kit the revision number on the slip is 11.

0 Likes
vivec_4189616
New Contributor

This is what i get when i program it using modus toolbox. Kindly suggest what changes do i need to do to program it using modus toolbox.Untitled.jpg

0 Likes
DheerajK_81
Moderator
Moderator

You aren't getting the silicon revision because you are using the old version (probably 3.27) of PSoC Programmer. Please use PSoC Programmer 3.28 . But since the board revision is 11 as you mentioned, it is an old revision and it will not work with ModusToolbox as seen from the table.

You will need a replacement kit and Cypress will be contacting you shortly.

Regards,

Dheeraj

View solution in original post

0 Likes
Top labels