cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6

NeWa_2626531
New Contributor

Hello

I use the CE217637 - BLE Find Me Profile on PSoC 6 BLE Pioneer Kit and work it correctly.

But when I used CE217637 - BLE Find Me Profile on a self-made PCBA, it didn't work. The program stopped at "apiResult = Cy_BLE_StackInit(&stackInitParam);"

also, I can control GPIO correctly before I execute "Cy_BLE_Start(NULL);", and I use the same MCU model as PSOC 6 BLE Pioneer Kit.

Thanks.

Neil

0 Likes
1 Solution
VenkataD_41
Moderator
Moderator

Hi,

I assume that you have not made any changes to the firmware of the Find me project. Please check the following points:

1. Check if you have followed the hardware design recommendations correctly from this document.

https://www.cypress.com/documentation/application-notes/an218241-psoc-6-mcu-hardware-design-consider...

2. You can also refer the development kit schematics and check once. Please refer CY8CKIT-062 kit schematics from the link below:

https://www.cypress.com/file/420836/download

The important points to be considered are the decoupling capacitors on the VCCD pin, VDDIO, VDDR pins.

If everything is correct and still you are facing the issue, please check the return of the API Cy_BLE_StackInit(&stackInitParam); and Cy_BLE_Start(NULL). Please update them in this thread.

Please ensure that you are using latest PDL (PDL 3.1.0).

Thanks

Ganesh

View solution in original post

0 Likes
1 Reply
VenkataD_41
Moderator
Moderator

Hi,

I assume that you have not made any changes to the firmware of the Find me project. Please check the following points:

1. Check if you have followed the hardware design recommendations correctly from this document.

https://www.cypress.com/documentation/application-notes/an218241-psoc-6-mcu-hardware-design-consider...

2. You can also refer the development kit schematics and check once. Please refer CY8CKIT-062 kit schematics from the link below:

https://www.cypress.com/file/420836/download

The important points to be considered are the decoupling capacitors on the VCCD pin, VDDIO, VDDR pins.

If everything is correct and still you are facing the issue, please check the return of the API Cy_BLE_StackInit(&stackInitParam); and Cy_BLE_Start(NULL). Please update them in this thread.

Please ensure that you are using latest PDL (PDL 3.1.0).

Thanks

Ganesh

View solution in original post

0 Likes
Top labels