cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ 6

LonghuiW_96
Employee

When debugging PSoC6 BLE, I encountered abnormal voltage between LDO and BUCK. The specific phenomena are as follows:

Buck mode Testing Data:

1. The normal voltage of VDD_NS and VDDD is 3.30v;

2.VDCDC  is 1.94v;

3. DVDD  is 1.58 V

4. VCCBUCK1 is 1.69 V 

5.VDDR1, VDDR2 and VDDR3 are 1.93v

6. VDDR_HVL is 2.30 V.

7. VCCD is 1.69 V

LDO mode Testing Data:

1. The normal voltage of VDD_NS and VDDD is 3.30v;

2.VDCDC  is 1.99v;

3. DVDD  is 1.58 V

4. VCCBUCK1 is 1.63

5.VDDR1, VDDR2 and VDDR3 are 1.83v

6. VDDR_HVL is 2.28 V.

7. VCCD is 1.66 V

  • The hardware circuit is as follows:
  • H1.png

       H2.png

       The software configuration is as followsNote: the code works well in the development version, but the MCU package is switched.)

           S1.png

0 Likes
3 Replies
ShipingW_81
Moderator
Moderator

The schematic looks fine. I'd like to check the code running state on your side.

How many boards tested, and this abnormal phemonen is a cretain case?

If you see the code get stuck at a certain place on this platform with abnormal power voltage, or runs finely? If the crystals get oscillated on your platform?

0 Likes
LonghuiW_96
Employee

1. Several boards have been tested, and the phenomenon is the same.

2. Other functions of the board are normal

3. The code is normally tested in the development version cy8ckit-062-ble, but the MCU model is changed.

4. Oscillated normal boot

0 Likes
ShipingW_81
Moderator
Moderator

Have you get any progress over this issue?

0 Likes
Top labels