cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 6

AyKo_4382201
New Contributor II

Hey,

I'm using CYBLE-416045-02 ble. For testing purpose I'm sending a 2 byte response into to a only read Response characteristic.

I'm able to get data from the ble app but cant send the 2 byte response.Please help.

Thankyou

0 Likes
1 Solution
Yugandhar
Moderator
Moderator

Hello,

Could you please refer to the below attached sample project. In this project, if you write two bytes of data from the central device then the values will be updated into the GATT DB at peripheral device. And, the updated values will be displayed in Central device through read response.

Please let me know if this helps.

Thanks,

P Yugandhar.

View solution in original post

0 Likes
6 Replies
Yugandhar
Moderator
Moderator

Hello,

Could you please refer to the below attached sample project. In this project, if you write two bytes of data from the central device then the values will be updated into the GATT DB at peripheral device. And, the updated values will be displayed in Central device through read response.

Please let me know if this helps.

Thanks,

P Yugandhar.

View solution in original post

0 Likes
AyKo_4382201
New Contributor II

Hi,

Thanks for replying. The project you have shared with me has errors as you can see in below attached image.Screenshot (6).png

0 Likes
Yugandhar
Moderator
Moderator

Hello,

I'm able to open the project at my end. Could you please try downloading again ?

Thanks,

P Yugandhar.

0 Likes
AyKo_4382201
New Contributor II

Hi,

Thanks, your project work fine. But i still have some questions:-

1) I have 2 characteristics named command (write only) and response (read only).

2) I'm able to communicate between psoc6 and mobile app only when i make response characteristic(which should be read only)  both read and write.

0 Likes
AyKo_4382201
New Contributor II

Continued...

Why am I not able to communicate both ways (app and psoc6) when i configure response characteristics as read only?

0 Likes
AyKo_4382201
New Contributor II

Thanks my problem has been solved.It was a typo error, I was using CY_BLE_SMARTDOOR_READ_PACKET_CHAR_INDEX instead of CY_BLE_SMARTDOOR_READ_PACKET_CHAR_HANDLE.

Again thanks for the help.

Top labels