cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ 5, 3 & 1

Anonymous
Not applicable

Hi,

   

 

   

I am fairly new to the PSoC community. I am working on a CYC8KIT-059 and I recently came into a problem that I cannot resolve.

   

 

   

Whenever I try loading a program onto the chip using the "program" button on PSoC Creator 3.3 a window pops up that says "select debug target" and the list is empty. Also, the USB status light (LED 3) does this slow, pulsing blink. This is the second board that this has happened to after previously having no problems with a different board.

   

 

   

I've read some topics dealing with this type of problem on the PSoC 4 that seem to point to the bootloader, but I'm not sure how to correct the problem.

   

 

   

Any advice would be greatly appreciated.

0 Likes
4 Replies
Bob_Marlowe
Expert II

You are in a different programming mode, press the switch for more than 5 seconds, blinking should change.

   

Your -059 has no bootloader, but the programming part has one. I would suggest you to update the KitProg to latest version:

   

Close Creator

   

Start PSoC Programmer 3.24.4 (update first, when you have got a lower version)

   

Select your KitProg. There could be a message (after a while) popping up telling you to update firmware. Do as advised.

   

Close Programmer

   

Unplug -059, count to 27 and re-plug

   

Wait for new drivers installed

   

Start creator

   

 

   

Happy coding

   

Bob

0 Likes
Anonymous
Not applicable

Dear Bob,

   

 

   

I am new to PSoC and want to start development using PSoC 5LP(I dont want to use PSoC 4 BLE module, hence I have removed it from the board)

   

I am using CY8CKIT-042-BLE  Pioneer Kit, when I try to program the kit I receive following dialog box

   

   

As I cannot expand the box and find PSoC 5LP, therefore I am not able to connect it and program or debug.

   

 

   

I am using PSoC creator 4.0 and  PSoC programmer 3.25.0 and i have updated the firmware but still no joy.

   

Please Help 

   

 

   

0 Likes
Bob_Marlowe
Expert II

You cannot do PSoC5 development with a CY8CKIT-042 without a MiniProg3. Best is to buy a CY8CKIT-059.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Thanks for the quick response 

0 Likes