cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1

Anonymous
Not applicable

 Good after noon everyone

   

i am  facing a problem in application note AN66627

   

when i programmed PSoC with example 1. it does not calculate speed of fan connected to it. and also it does not generating any pwm pulse on p0.5 of uc.

   

i have also connect p0.5 to oscilloscope to confirm that it is generating any output or not. but it is not generating any pulse.

   

i am confused about this. may be fan controller component is not working properly.

   

is anyone use it successfully?

   

i am using kit CY8CKIT-001 and PSOC3 plateform. and 4-pole dc fan (12v,0.40A, 45dBA noise)

   

suggest some solution to this problem.

0 Likes
8 Replies
Bob_Marlowe
Expert II

What is your interface between the fan and your board, since the PSoC is not able to drive 400 mA

   

 

   

Bob

0 Likes
Anonymous
Not applicable

yes i know that. that's why i have given power to fan  from another 12v supply, i just connect pwm and tech signal of fan directly to psoc. as these signal are digital in nature  and can be connect to any UC directly.

0 Likes
ETRO_SSN583
Esteemed Contributor

Thats odd, in example 1 of this ap note I do not see any p 0.5 connections comitted.

   

 

   

0 Likes
Anonymous
Not applicable

thank you sir

   

but this diagram belongs to  Themal management expansion board kit CY8CKIT-036 example 1 for host kit-001. but i am talking about Psoc3 and PSoc5 intelligent fan controller (application note 66627 by  Jason Konstas).

   

link for this is 

   

http://www.cypress.com/?rID=49077

   

 

   

but this is not a problem any more . we can connect output of bank  of fan controller to any port to which we want. main problem is that fan controller output is given to any port but when we connect this signal to fan it is not controlling speed of fan.

   

i also use the output of that pin to oscillscope to see whether it is generating any pulse or not. but there is no pulse

   

at that pin

   

means fan controller either does not generate pwm pulse of particular frequency and duty cycle or any other thing that i am unable to find.

   

 

   

 

   

then what is the problem?

   

i want to know about that

   

why it is not generating any pulse. or i am monitoring in a wrong way

   

to see the output of that pin. i simply connect 1 wire from that pin to positive terminal of osciloscope and gnd of osciloscope is connected to gnd of processor module. am i right?

   

 

   

i also connect this signal to fan but there is no change in speed  of fan as i am changing duty cycle via switchs

0 Likes
ETRO_SSN583
Esteemed Contributor

I went to that link, opened all 5 projects, cannot see a single project with P_0_5 connected to anything ?

   

 

   

Archive the project you are working with and post it.

   

 

   

Regards, Dana.

0 Likes
Anonymous
Not applicable

 may be that project is modified by cypress.

   

i am uploading that project i am working with. 

   

port pin is not problem. problem is why it is not generating a pwm pulse?

0 Likes
Anonymous
Not applicable

 and application note is also attached with this post. please see it.

0 Likes
Anonymous
Not applicable
0 Likes