cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1

Anonymous
Not applicable
        Hello, I have PSoC creator software 3.0. (PSoC5LP, CY8C5867AXI-LP024) The debugger is almost anytime hung-up when I do "stop at breakpoints", "stepwise execution", and so on. If the AUTO variables in the function change to STATIC, the debugger isn't hung-up. (It still may not be improved. ) The "Program" have no problem. Only "Debug". Does anyone have a clue how I can get rid of this problem? Thank you.   
0 Likes
1 Solution
Bob_Marlowe
Expert II

After

   

1st Updating your project to latest component versions

   

2nd Changing the target device to my Cy8c5868

   

3rd Changing the Project settings for "Skip Code Generation" to FALSE (!!!)

   

the project compiled with warnings and could be debugged as usual.

   

 

   

Bob

View solution in original post

0 Likes
11 Replies
Bob_Marlowe
Expert II

Are you using a development kit or your own board?

   

Is it possible that you upload your complete project, so that we all can have a look at? To do so, use Creator -> File -> Create Workspace Bundle and then attach the resulting archive (do NOT use chrome, will not work)

   

 

   

Bob

0 Likes
Anonymous
Not applicable
        Thank you for your response. I'm using my own board. So I may need to check the behavior of the development kit... The complete project is too large, so I'll make and upload smaller project what have the same problem at tomorrow. Thank you.   
0 Likes
Anonymous
Not applicable
        Hello, I've updated the project what have the problem. This program is USB echo back program, but not only this program have the problem. Push "Debug", and stop at start of MAIN (uint8 length = 0;), then already I can't do "stepwise execution", can't look at Memory Map(displayed "##"), and can't look at local variables. "Stop Debbuging" is only enable. If I changed the AUTO variables in the function to STATIC, ((ex) static uint8 BufData[0xF8]; static uint8 length = 0;) then, those processes is enable. I'll also try check the behavior of the development kit. Then I'll report later. Thank you.   
0 Likes
Anonymous
Not applicable
        Hello, I debugged with the development kit(CY8C5868AXI-LP035). I used the same code. The result was the same phenomenon. Have anyone seen such a phenomenon? Or Does anyone have a clue how I can get rid of this problem? Thank you.   
0 Likes
Bob_Marlowe
Expert II

I am going to set up a test-equipment and check your Project, stay tuned.

   

Some comments:

   

Update Creator to latest version, there have been improvements of the components.

   

You have got some warnings, address each of them and code (some type casts help) in a way that they dissapear

   

using "&Buffer" is darn wrong: Buffe is an array, so "Buffer" already IS the address of the array and the preceding "&" will turn that into the address of a pointer,

   

Until Later

   

Bob

0 Likes
Bob_Marlowe
Expert II

After

   

1st Updating your project to latest component versions

   

2nd Changing the target device to my Cy8c5868

   

3rd Changing the Project settings for "Skip Code Generation" to FALSE (!!!)

   

the project compiled with warnings and could be debugged as usual.

   

 

   

Bob

View solution in original post

0 Likes
Anonymous
Not applicable
        Test.\n I can't insert line feeds.   
0 Likes
Anonymous
Not applicable
        Test.   
I can't insert line feeds.   
0 Likes
Anonymous
Not applicable
        Hello, Mr.Bob Marlowe.   
   
Thank you for your trying and advices. I updated this project to latest component versions, I have been able to debug as usual! I'm so grateful to you.   
   
> 3rd Changing the Project settings for "Skip Code Generation" to FALSE (!!!)   
I apologize for the confusion. It is intentional act.   
The code made automatically can't connect with WinUSB. So, I changed "USBUART_descr.c" by myself.   
But this issue has no relation with WinUSB. Also, the component updated need to be reflected. So, I had to change "Skip Code Generation" to FALSE.   
   
By the way, this Community has "Rewards Program". How can I give you some rewards?   
0 Likes
Bob_Marlowe
Expert II

Thank you for offering rewards to me, You are always welcome!

   

I collected so many reward points already that I could buy the store empty, I do not use them.

   

And no "Mr.", please, Simply

   

Bob

0 Likes
sefu_4590011
New Contributor II

Hello,

I had a similar problem and just in case anyone else finds this thread in search of help I want to contribute my solution.

For me it helped to change the setting
Build Settings → ARM GCC 5.4-2016-q2-up → Linker  → Optimization → Remove Unused Sections
from True to False

This increased flash use to more than double than before but debugging works now as it should.

0 Likes