cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 5, 3 & 1

Anonymous
Not applicable

Hi All,

I use CY8CKIT-059 prototyping kit. When I tried to use the component of  ADC_SAR_SEQ to receive external analog signals, I met with trouble.

I copied my setup and the problem blow.

pastedImage_2.png

pastedImage_1.png

pastedImage_3.png

pastedImage_4.png

pastedImage_5.png

When I build the program, it shows that "vdac_ref" on ADC_SAR_SEQ_v2.0 is unconnected. I am not sure how to connect this hidden pin. I have to connect it to a DAC output pin?

Thank you in advance.

Jim

0 Likes
1 Solution
HeLi_263931
Honored Contributor II

tl;dr: Yes. No.

Yes, you can ignore this message. It neither an error nor a warning, its purely informational.

No, I don't think its a bug, it actually tells you the truth: Vref is actually _not_ connected to a terminal - you are using internal Vref. (So this message should not appear when you are using external Vref, or even when using buffered Vref [which is preferred anyway])

Cypress might consider it a bug that the write internal (debug?) messages to the console log.

The only bug here might be that the signal seems to named wrong: its _vdac_ref_ whereas it probably should be _vadc_ref_.

View solution in original post

0 Likes
4 Replies
HeLi_263931
Honored Contributor II

This is just an informational message (as seen by the icon). So you can safely ignore it.

0 Likes
Anonymous
Not applicable

Thanks very much for your response. You mean that I can ignore this error message? in another words, this message is a bug?

0 Likes
HeLi_263931
Honored Contributor II

tl;dr: Yes. No.

Yes, you can ignore this message. It neither an error nor a warning, its purely informational.

No, I don't think its a bug, it actually tells you the truth: Vref is actually _not_ connected to a terminal - you are using internal Vref. (So this message should not appear when you are using external Vref, or even when using buffered Vref [which is preferred anyway])

Cypress might consider it a bug that the write internal (debug?) messages to the console log.

The only bug here might be that the signal seems to named wrong: its _vdac_ref_ whereas it probably should be _vadc_ref_.

View solution in original post

0 Likes
Anonymous
Not applicable

Thanks again and again for your help.

One more thing is that I tried to use three Wave DAC8, but some one no output and some output is clamped, I checked everything and they seem good.

Regards

Jim

0 Likes