Announcements
Community Announcement : Welcome to the NEW Cypress Developer Community.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4

Sophie_Wang
New Contributor II

Dear friend,

   

I have a code changed from project day17 pricvacy. the peripheral will broadcast from public addr to private addr after connected. but something wrong happened. when the central is power off, the peripheral should detect disconnected and readvertise with private addr, the stack enter CYBLE_EVT_GAPP_ADVERTISEMENT_START_STOP once, then fast adv timeout, stack enter CYBLE_EVT_GAPP_ADVERTISEMENT_START_STOP twice, peripheral start slow adv, stack  enter CYBLE_EVT_GAPP_ADVERTISEMENT_START_STOP third time, and when slow adv end, stack should enter CYBLE_EVT_GAPP_ADVERTISEMENT_START_STOP. but now I can only see stack enter CYBLE_EVT_GAPP_ADVERTISEMENT_START_STOP three times. could you please help to check why slow adv won't end?

   

Thank you! 

0 Likes
1 Solution
Sophie_Wang
New Contributor II

Dear Haneesh,

   

please enable the slow advertise,then you can see the phenomenon

   

thanks

   

sophie

View solution in original post

0 Likes
2 Replies
Anonymous
Not applicable

I have gone through the projects and tested the peripheral project. In component configuration, slow advertising is not enabled (not checked). Hence, CYBLE_EVT_GAPP_ADVERTISEMENT_START_STOP triggers only twice (during start of fast advertising and time out of fast advertising).
The project works as expected for me.

0 Likes
Sophie_Wang
New Contributor II

Dear Haneesh,

   

please enable the slow advertise,then you can see the phenomenon

   

thanks

   

sophie

View solution in original post

0 Likes