cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ 4

Anonymous
Not applicable

As I build up my project I see that I have a few unused pins until I enable their specific components.

   

For example I have a line that may be used as an interrupting digital input from an I2C slave.  I have actually physically connected the Int line from the I2C slave to port p[3]5 but I have not addressed it in my TopDesign yet.  Until I decide if I want to used that interrupt from the I2C slave, how should I assign that pin in my TopDesign?

   

Also, I have a 4 button Capsense slider that I have created on my board and have installed a Cmod capacitor on pin p[4]0 and the slider pads on p[4]1, p[5]0, p[0]5 and p[4]4.  I do not have a CapSense component yet on my TopDesign.  Until I get around to testing this slider, what should I put on the TopDesign for this pins?

   

I have tried various combinations of high impedance analog and digital inputs with and without HW connections but find this a rather random procedure since some of those pins are not able to be high impedance digital pins with HW connection which is what my best guess was as to how they should be set in code until I use them.

   

Thanks,

   

Dale

0 Likes
6 Replies
Bob_Marlowe
Expert II

Dana just posted in another thread with same question. Look at this knowledge base article.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Thanks Bob,

   

That does help some, however, p[4]0, p[4]1 and p[5]0 'can not be used for routed connections' so the only way I can build the project is to set those ones to analog, strong, low instead of the recommended (I think) digital, strong, low.

   

What do you think?

   

Dale

0 Likes
Bob_Marlowe
Expert II

You do not need to route the pins. Just remove the check for hardware-connection and set the port drive mode and state accordingly.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

On the EZ-BLE that does not work on port bank 4 and 5 as the error still says the whole port is not available for routed connections with HW connection unchecked on any pin in those ports set to digital input.

   

Dale

0 Likes
Anonymous
Not applicable

Hi Dale, 

   

You could try to put those pin in transparent mode. This option is in the output tab/Output mode.

0 Likes
Anonymous
Not applicable

Thanks, but along the way way I found another cypress doc that said that recommended  HiZ analog.  Can't remember where I found that.

0 Likes