cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4

Anonymous
Not applicable

First of all, after program  the code (build the project + program main.c). and press SW 2 the motor not rotate as well. (And i redo it press SW1 to reset and SW2 to start the motor). By the way the problem is.

1. No bug ( successful when compile the code, also update the component), no blinking and light on LED 2 on EVK board

2. my input is 5VDD on 042 pioneer kit, and the wire connected red ,yellow, black.  and the jumper.

So anyone can tell me what's the factor of this problem and how can i fixed. Thanks for your advise.

1 Solution
JobinT_31
Employee

When LED1 is red, it indicates power is on. If it is not glowing, the fuse F2 may be broken. Please change the F2 with the provided backup fuse.

As mentioned in the user guide: http://www.cypress.com/file/141156/download    5.3.5.4 Step 4 – Connect the Power Supply and Motor . Please go through the manual.

Thanks

Jobin GT

View solution in original post

0 Likes
8 Replies
NoriakiT_91
Employee

I assumes that you are using the CY8CKIT-037 with the CY8CKIT-042.

Please refer the CY8CKIT-037 Motor EVK User Guide.  The document can be downloaded from the following page or installed with the CY8CKIT-037 kit setup.

CY8CKIT-037 PSoC 4 Motor Control Evaluation Kit | Cypress Semiconductor 

The Kit Program has five firmware as follows.

  1. Sensored BLDC Motor Control example project
  2. Sensorless BLDC Motor Control example project
  3. Sensorless Foc Motor Control example project
  4. SingleShunt Foc Motor Control example project
  5. Stepper Motor Control example project

Which firmware did you program?

The CY8CKIT-037 PCB has so many jumper pins to support above five kinds of Motor Control firmware.  Did you configure these jumper pins following the description in the Kit Guide document like as following example?

GS003309.png

Did you connect the sensor connector as well as the power lines as follows?

GS003310.png

Regards,

Noriaki

Anonymous
Not applicable

II'm used Sensored BLDC motor control firmware

and i follow the instruction but the motor can not rotate.

0 Likes
JobinT_31
Employee

Since LED2 is not blinking there is no error detected by the firmware. Error such as zero-crossing detection failure, overvoltage happens,  undervoltage happens, freerun stage fails, fail to enter close loop.

Believing the jumper configurations are correct, we can suspect any issue in the sensor. Try running the "Sensorless BLDC Motor Control Example Project" don't forget to change the jumper configuration correctly.

Thanks

Jobin

0 Likes
Anonymous
Not applicable

Thanks.

By the way, i'm already try to running Sensorless BLDC Motor Control and config the jumper. But their still the same as previous problem. The motor didn't rotate.

For the error zero-crossing detection failure, overvoltage, undervoltage, freerun stage fail, How can i fixed that's problems. Sorry, i'm a newbie for electronic device and embedded system.

0 Likes
JobinT_31
Employee

Confirm the status of LED1 in the 037 kit, near to R11.

Jobin

0 Likes
Anonymous
Not applicable

Status of LED1 near R11 is off. What's that mean ?

0 Likes
JobinT_31
Employee

When LED1 is red, it indicates power is on. If it is not glowing, the fuse F2 may be broken. Please change the F2 with the provided backup fuse.

As mentioned in the user guide: http://www.cypress.com/file/141156/download    5.3.5.4 Step 4 – Connect the Power Supply and Motor . Please go through the manual.

Thanks

Jobin GT

View solution in original post

0 Likes
JobinT_31
Employee

When LED1 is red, it indicates power is on. If it is not glowing, the fuse F2 may be broken. Please change the F2 with the provided backup fuse.

As mentioned in the user guide: http://www.cypress.com/file/141156/download 5.3.5.4 Step 4 – Connect the Power Supply and Motor . Please go through the manual.

Thanks

jobinb GT

0 Likes