cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4

Anonymous
Not applicable

Hi.

   

 

   

I've got Psoc 4 l-series pioneer kit and I'm trying to use the UART USB example (this SDK http://www.cypress.com/documentation/development-kitsboards/cy8ckit-046-psoc-4-l-series-pioneer-kit)

   

The UART communication wasn't responding in any way so I started going trough the kitprog user guide for this kit (http://www.cypress.com/file/226201/download).

   

I've used the PSoC Creator ( 3.3 SP1 (3.3.0.7343)) for flashing and debugger works fine.

   

The kitprog user guide however mentioned updating the firmware for the kitprog and that's not working. If I start up the PSoc  programmer (3.25.0.2504) it doesn't contain the CY8C4xxx -family. Should I be able to upgrade the firmware via this tool or is the info in the documentation obsolete? Or is the problem the CCG3 SDK that I had installed before (I uninstalled it before installing this).

0 Likes
3 Replies
Bob_Marlowe
Expert II

You need Cypress Creator 4.0 SP1 as the latest version.

   

Updating the Kitprog to latest is also required. It is not necessary to select the device family in PSoC programmer, this info is taken from the hex-file you want to flash.

   

 

   

Bob

0 Likes
Anonymous
Not applicable

Ok, plot thickens.

   

 

   

"Log file for this session is located at: C:\Users\msillanpaa\AppData\Local\Temp\PSoC Creator-001.log Warning: Port KitProg/1B150EEB02105400 in use KitProg version Expecting 2.17, but found 2.16. Please use PSoC Programmer GUI to upgrade firmware."

   

The Programmer Still doesn't contain the right family. And the "Upgrade Firmware" -button in the "Utilities" -page isn't active.

0 Likes
Bob_Marlowe
Expert II

Follow the instructions in the Kitprog manual to update:

   
        
  • insert Kit
  •     
  • start programmer
  •     
  • select kitprog
  •     
  • wait until check via internet for actual version displays
  •     
  • select "Utility" and update
  •    
   

 

   

Bob

0 Likes