Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

Anonymous
Not applicable

Hello

   

I have a CY8CKIT-042-BLE Pioneer Kit with BLE 4.1 modules (PSoC & PRoC). I'm wondering is it possible to get 4.2 BLE functionality using stack firmware updates or it requires a new hardware IC?

   

With best regards, Sergey

0 Likes
1 Solution
Anonymous
Not applicable

Sergey,

   

The new Bluetooth 4.2 Kits and PSoC Creator 3.3 Service Pack 1 where released in late January this year. 
It will work with any release after (PSoC Creator 3.3 Service Pack 1 ) for example as of today (PSoC Creator 3.3 CP2)

   

Since you already have a PSoC4-042 BLE DVK - you will need to update your modules.
* CY5676A: PRoC BLE development kit with Bluetooth 4.2 radio
* ​CY8CKIT-143A: PSoC 4 BLE development kit with Bluetooth 4.2 radio
* CY5677: BLE-USB bridge to test and debug designs using Bluetooth 4.2

- For more information:
http://www.cypress.com/blog/psoc-creator-news-and-information/new-bluetooth-42-kits-and-psoc-creator...

   

-Mike

View solution in original post

0 Likes
8 Replies
Anonymous
Not applicable

Sergey,

   

The new Bluetooth 4.2 Kits and PSoC Creator 3.3 Service Pack 1 where released in late January this year. 
It will work with any release after (PSoC Creator 3.3 Service Pack 1 ) for example as of today (PSoC Creator 3.3 CP2)

   

Since you already have a PSoC4-042 BLE DVK - you will need to update your modules.
* CY5676A: PRoC BLE development kit with Bluetooth 4.2 radio
* ​CY8CKIT-143A: PSoC 4 BLE development kit with Bluetooth 4.2 radio
* CY5677: BLE-USB bridge to test and debug designs using Bluetooth 4.2

- For more information:
http://www.cypress.com/blog/psoc-creator-news-and-information/new-bluetooth-42-kits-and-psoc-creator...

   

-Mike

0 Likes
Anonymous
Not applicable

Hello,

   

Why is it not possible to only update the BLE stack?  Is this the case with all modules and all new version of Bluetooth?

   

Thanks

0 Likes
Anonymous
Not applicable

Thanks, Mike!

0 Likes
Anonymous
Not applicable

Hello,

   

Does it mean that we have to change the hardware for each new version of Bluetooth?

   

Thanks

0 Likes
Anonymous
Not applicable

Hello,

   

Why is it not possible to only update the BLE stack?  Is this the case with all modules and all new version of Bluetooth?

   

Thanks

0 Likes
himam_31
Employee
50 likes received 25 likes received 10 likes received
Employee

Hello Marc,

   

BLE 4.1 to 4.2 requires hardware changes also. The change is not just limited to the BLE Stack.

   

Thanks,

   

Hima

0 Likes
Anonymous
Not applicable

Hello Hima,

   

If I sell a product that use a Cypress BLE module, should I consider to change the hardware in the field for each new version of Bluetooth ?

   

Thanks,

   

Marc

0 Likes
himam_31
Employee
50 likes received 25 likes received 10 likes received
Employee

Yes.

   

Thanks,

   

Hima

0 Likes