Announcements
Community Announcement : Welcome to the NEW Cypress Developer Community.
cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC 4

AnKr_1499391
New Contributor II

Hi,

   

I was working for more than a year now with the Cypress BLE-Kit and startet with the old 128kB Module, then switched over to the 256kB modules and it went very smooth.

   

But now I ordered some of the new CY8CKIT-143A with the new BLE 4.2 support and after updating the device and the components BLE just won't work.

   

Because my project is very complex, I tried with the Bonding-Example of day 15 from the blog, but even this doesn't work.

   

After fixing the printf for the passkey-display, I can now pair with the device again. But the Cypress-App doesn't show any services. Only an empty page with "No services found".

   

I'm not sure if that is a problem with the module or the app. Does anybody else have this problem?

   

I added my modified example for testing.

   

Thanks

   

Andreas

0 Likes
1 Solution
AnKr_1499391
New Contributor II

Hi,

   

I indeed got it working in the end.

   

Somehow it seemes that the BLE-Component was configured as GATT-Client. This is why I didn't see any services in the App.

   

I forgot to post this information to this topic.

   

Thanks for your help.

   

Andreas

View solution in original post

0 Likes
2 Replies
Anonymous
Not applicable

Hi,

   

Did you check any of our example projects in PSoC Creator with the module? If so, did it work?

   

Regards,

   

-Madhu Sudhan

0 Likes
AnKr_1499391
New Contributor II

Hi,

   

I indeed got it working in the end.

   

Somehow it seemes that the BLE-Component was configured as GATT-Client. This is why I didn't see any services in the App.

   

I forgot to post this information to this topic.

   

Thanks for your help.

   

Andreas

View solution in original post

0 Likes