Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4 Forum Discussions

AkKa_1244106
Level 1
5 questions asked First like given 5 sign-ins
Level 1

We are developing a LIN 2.1 slave device using CY8C4146LQA-S433.

The LIN component datasheet states that it supports 2.2, 2.1 or 2.0.

However, there is no 2.1 choice in the component properties.

ConfigureLIN.PNG

Please tell me how to use it with the LIN2.1 specifications.

0 Likes
1 Solution
Ashish
Moderator
Moderator 25 likes received 50 solutions authored 100 replies posted
Moderator

Hi,

You can just select 2.2 compatibility, as both LIN 2.2 node is  "fully compatible" with 2.1 node. Also, I checked the difference between the two versions in LIN 2.2 spec,  I found there is no significant difference (only spelling correction and clarification). 

Capture_a.PNGCapture_b.PNG

Kind Regards,

Ashish

View solution in original post

0 Likes
2 Replies
Ashish
Moderator
Moderator 25 likes received 50 solutions authored 100 replies posted
Moderator

Hi,

You can just select 2.2 compatibility, as both LIN 2.2 node is  "fully compatible" with 2.1 node. Also, I checked the difference between the two versions in LIN 2.2 spec,  I found there is no significant difference (only spelling correction and clarification). 

Capture_a.PNGCapture_b.PNG

Kind Regards,

Ashish

0 Likes
AkKa_1244106
Level 1
5 questions asked First like given 5 sign-ins
Level 1

Hi Ashish,

Thank you for reply.

I understand from your explanation.

Best Regards,

Kanda

0 Likes