cancel
Showing results for 
Search instead for 
Did you mean: 

PSoC™ 4

ishwariy_joshi
New Contributor II

Hello Community!,

I Have KitProg2 which is come with this kit

it works well when I'm using it for few weeks. on my office Desktop Computer and as well as in Personal laptop too.

but suddenly it stopped directing in the PSoC programmer Software which is installed on my Laptop. but it still works in my Office Desktop Computer. in both of the machine I have installed the Same PSoC Creator IDE Full. in both machines I'm an Administrator User. KitProg2 Detect in Devices manager of my Laptop but, it's not showing in PSoC programmer See the images. On my Laptop I have  reinstalled Whole the PSoC environment (IDE+Programmer). but still, it's not working. 

 

Office Desktop Computer: (Detect in Device manager as well as in PSoC programmer)

WhatsApp Image 2021-05-07 at 10.12.16 AM.jpeg

 

 

 

 

 

 

 

 

 

 

 

 

 

 

My Personal Laptop:  (Detect in Device manager But not  in PSoC programmer)

Screenshot (58).png

 

Don't know what's the problem.

I hope this can resolve with Community supports.

Thank You 🙂

 

 

0 Likes
3 Replies
LinglingG_46
Moderator
Moderator

1: When the Port Selection can't show the device, if you click the "Utilities", then choose the "Upgrade Firmware", what's the system feedback?

2: What's the LED3 status when the Port Selection can't show the device? Does it enter the Mass  Storage Mode?

3: Please refer to the kitprog2 user guide in your kit installation directory.

 

 

0 Likes
ishwariy_joshi
New Contributor II

1. I connect Kitprog2 with my laptop and checking for Firmware update into utility section but nothing is there. But, when i connect to my Desktop computer then its showing me firmware update. I update firmware from office desktop computer. But still it's not working in my Laptop.

2. Status of LED3 and LED2 is ON.

it's NOT  under the mass storage mode i check that.

3. I check that but nothing related to this problem.

 

Thank you. 

0 Likes
Roy_Liu
Moderator
Moderator

Looks strange phenomenon, one point I can think of is please make sure your personal laptop has only one PSoC Programmer running at the same time. Restart the laptop may also worth try.

P.S. the kitprog you are trying looks kitprog3(from the screenshot you attached), but not kitprog2.

Roy Liu
0 Likes