Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

PSoC™ 4

AnMo_4196841
Level 3
First like received First like given
Level 3

Hi people,

I get this error when executing my project, which is based on a BLE connection where I use the devices shown in the attached photo.

I tried to uninstall and reinstall PSoC Creator but it still gives me the same bug.

Any ideas to fix it? It is the only mistake it gives me.

Greetings

0 Likes
1 Solution
MotooTanaka
Level 9
First comment on KBA 1000 replies posted 750 replies posted
Level 9

Hi,

I tried to build your project.

The last 4 lines were.

====================

.\CortexM0\ARM_GCC_541\Debug\main.o:(.bss+0x0): multiple definition of `deviceConnected'

.\CortexM0\ARM_GCC_541\Debug\BLE_APP.o:(.bss+0x0): first defined here

collect2.exe: error: ld returned 1 exit status

The command 'arm-none-eabi-gcc.exe' failed with exit code '1'.

--------------- Build Failed: 10/27/2019 20:49:24 ---------------

====================

This error message suggests that both you and the library have identifier named "deviceConnected"

In your main.c there were two lines which has "deviceConnected".

So I changed "deviceConnected" to "device_connected" in your main.c.

And now your project is build-able.

Attached is modified project of yours 😉

moto

View solution in original post

3 Replies