cancel
Showing results for 
Search instead for 
Did you mean: 

Bluetooth SDK

GeIo_1586191
Contributor II

I just purchased a Lenovo Tab 7 tablet which uses Android OS 8 (GO) and thus meets the minimum Android SDK version criteria for the apk (I originally tried using my old Amazon Fire tablet but failed as Fire version too old and had an old Tab 7 + smartphone which only had Android 5.1).

I was therefore able to upload the app and open it without problem and could create my network name etc. However, the app is unable to find any devices when I scan for them, even though I can see the Mesh device when I scan using a BLE utility app on my tablet.

I was wondering if this has anything to do with the fact that the Lenovo Tab 7's Bluetooth version 4.0. The mesh documentation is not clear on which BLE version is required.

0 Likes
1 Solution
GeIo_1586191
Contributor II

Just to confirm that the app is now working on the Lenovo Tab7 (Bluetooth 4.0).

I decided on dinner and a rest, then rebooted my tablet, reflashed the device with the available light dimmable example, opened up serial monitor (this time) to confirm working correctly and then was able to see the device on the app when clicking on "Add device".

Now very happy with the App.

View solution in original post

0 Likes
2 Replies
GeIo_1586191
Contributor II

Just to confirm that the app is now working on the Lenovo Tab7 (Bluetooth 4.0).

I decided on dinner and a rest, then rebooted my tablet, reflashed the device with the available light dimmable example, opened up serial monitor (this time) to confirm working correctly and then was able to see the device on the app when clicking on "Add device".

Now very happy with the App.

View solution in original post

0 Likes
DheerajPK_41
Moderator
Moderator

Hi GeIo_1586191​,

Happy to hear that you are very much happy with the mesh app.

And I liked the way you solved the problem. (=>I decided on dinner and a rest, then rebooted my tablet).

Thanks,

-Dheeraj