cancel
Showing results for 
Search instead for 
Did you mean: 

Bluetooth SDK

giladitz
New Contributor

Hi,

As it was mentioned in this discussion:
https://community.cypress.com/t5/ModusToolbox-Bluetooth-SDK/CYW20819-Braktooth/m-p/288395#M2065

There is an issue from Braktooth for CYW20735 which affects CYW20819 as well (https://community.cypress.com/t5/Security-Bulletin/Bluetooth-Denial-of-Service-Vulnerabilities-Brakt...).

The said patch "will be available in BTSDK 3.2 (available in late Q4 2021)".

My questions are:
1) Will this vulnerability affects devices CYW43353 and CYW4343W?
2) When will a patch be available for devices CYW43353 and CYW4343W, and what form will it take?

Thank you.

0 Likes
1 Solution
DheerajPK_41
Moderator
Moderator

Hi,

This vulnerability affects only the Bluetooth Classic.  Are you using these chips for any Bluetooth Classic applications?

 

Thanks,

-Dheeraj.P.K

View solution in original post

0 Likes
4 Replies
DheerajPK_41
Moderator
Moderator

Hi,

This vulnerability affects only the Bluetooth Classic.  Are you using these chips for any Bluetooth Classic applications?

 

Thanks,

-Dheeraj.P.K

View solution in original post

0 Likes
giladitz
New Contributor

Hi,

Yes, we are using it also with Bluetooth Classic for some applications.

Thanks.

0 Likes
giladitz
New Contributor

Hi @DheerajPK_41,

In case we are using Bluetooth Classic with CYW43xxx, will a patch be available for those devices (CYW43353 and CYW4343W) and what form will it take?

Thank you.

0 Likes
DheerajPK_41
Moderator
Moderator

Hi,

You can get the patched HCD files from us or module vendor. The fixes are currently under validation. Please create a salesforce case or contact our sales team to get the patched firmware.

Thanks,

-Dheeraj.P.K

0 Likes