Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

XMC™ Forum Discussions

Not applicable
Hi there,

We would like to build an automated testing setup for our xmc4700. To do that we want to flash the firmware from a raspberry pi 3 via an xmc-link (v1.1) to an xmc4700.

What we did:

- Downloaded and installed Segger tool for ARM from here (https://www.segger.com/downloads/jlink/. )
- Added the install location of the segger tools to the PATH variable in the .bashrc file.
- When we connected the Jlink via USB and started the JlinkExe we got the following error:

"
pi@raspberrypi:~ $ JLinkExe
SEGGER J-Link Commander V6.16c (Compiled Jun 16 2017 18:19:34)
DLL version V6.16c, compiled Jun 16 2017 18:19:11

Connecting to J-Link via USB...FAILED: Cannot connect to J-Link via USB.
J-Link>
"

When we tried it from a windows pc it works fine.

Furthermore the DEBUG-LED at the xmc-link is constantly iluminated green and the COM-LED constantly red.
When we tried form the Windows PC the DEBUG-LED is also constantly green and the COM-LED off.

Has anyone ever tried to flash firmware from the raspberry pi to the xmc? Are there maybe other options than the xmc-link?

Thanks for your help!

Nicolas
0 Likes
1 Reply
Not applicable
Solved!
by executing "sudo ./JLinkExe" in the JLink folder it worked
0 Likes