Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

XMC™ Forum Discussions

Not applicable
Hello there,

i received two XMC2Go with the XMC1100 and started to develop a WS2812B LED control application to get comfortable with the XMCs.

Now my next step was to interface the XMC via USB using the VCOM feature it is said to have.
Unfortunately i face two problems, which are not directly related to each other and are persistent on both XMC2Go's.
Maybe you can give me some hints what i am doing wrong, or how to workaround the problems.


Problem a)
According to the XMC2Go schematic [1], the pins P2.1 and P2.2 are used for VCOM TX and RX.
If i read the wiring correctly, P2.1 has to be TX and P2.2 has to be RX.
Looking at the XMC1100 TRM [2], Page 18-47, port P2.2 can only be configured as DX3A/DX4A/DX5A.
And USIC description says, only DX0 is to be used for RX data in ASC mode. (TRM Page 14-54).
I could use multiple data lines in parallel, but for pure serial, only DX0 is allowed to be selected.
Using DAvE to configure the RX pin to P2.2 results in no code being generated for initializing any USIC's DXnCR.

To me it looks like the port pin selection P2.1/P2.2 doesn't make sense for USIC RX/TX?
Question: Which registers do i have to set up to select DX3 as RX line for the bit shifter?



Problem b)
Working around the first problem by not using Rx path, i came across the problem that SEGGER JLink configurator is telling me,
that "The connected debug proble does not support VCOM functionality" and leaves the "Virtual COM-Port" setting fixed at "Disable".
Nevertheless Windows found a virtual COM port named "JLink CDC UART Port (COMx)" that does not return any data written by the XMC1100.
Tried the other way: When writing data to this COM port using various terminal tools and "echo test > COMx", the XMC2Go's XMC4200 doesnt serve any data at his TX port (also not on RX)

Even tried updating the firmware of the XMC4200 by installing SEGGER driver v4.90d, as DAvE came with v4.84f. That didnt help either.

Question: How do i correctly install a VCOM driver that works with the XMC2Go? (WinXP x86, Virtual Box machine)


Thanks,
Georg


[1] XMC2Go Schematics: http://www.infineon.com/dgdl/Board_Users_Manual_XMC_2Go_Kit_with_XMC1100_R1.0.pdf?folderId=db3a30433...
[2] XMC1100 Reference Manual: http://www.infineon.com/dgdl/xmc1100_rm_v1+0_2013_03.pdf?folderId=db3a30433580b3710135a47f3eb76c98&f...
0 Likes
1 Reply
Not applicable
ok small update:

Problem a)
Solved by using USIC0_CH0.DX0G which goes to DX3INS and therefor uses DX3. (doh....)

Problem b)
This doesnt happen when using a W8 x64 machine.
Still persistent for Win XP virtualbox machine 😞
0 Likes