Tip / Sign in to post questions, reply, level up, and achieve exciting badges. Know more

XMC™ Forum Discussions

User9154
Level 4
Level 4
Hallo,
Do I exchange on KIT_XMC11_BOOT_001 used IC XMC1100.. with XMC1302T038X0200AAXUMA1?

What should I change in Dave3.10. to work properly?
best regards
zbyno
0 Likes
20 Replies
Not applicable
Hi zbyno,

Not sure if I get your question correct..
Do you mean you want to replaced the device on the KIT_XMC11_BOOT_001 with XMC1302T038X0200AAXUMA1 device and how to setup in DAVE3.10?
If yes, all you need is just create your project with XMC1302-T038X0200.
0 Likes
User9154
Level 4
Level 4
Hi Jackson
Yes, you have it correct understood.
I haven´t done this exchange, my question is : if it would be possibly...
regards
zbyno
0 Likes
Not applicable
Hi zbyno,

Yes, that is possible.
The pins for XMC1100 are compatible with XMC1302.
You can replaced it directly.
As for the DAVE project, you just select your target device as XMC1302 when creating a new project.
0 Likes
User9154
Level 4
Level 4
Thank you Jackson
have a nice day..
zbyno
0 Likes
User9154
Level 4
Level 4
Hi Jackson,
Where can I get about 2 pcs free samples of XMC1302T038X0200 ? I will to upgrade my XMC1100_boot_board to XMC1302 (do it yourself).
It is fast unpossible to buy a board with XMC1302...
It is possible?
regards
zbyno
0 Likes
Not applicable
Hi zbyno,

Do you have any contact with our IFX sales rep or FAEs?
If yes, they should be able to help you with the free sample.
Or you could contact your preferred distributor and I believe they could help you with the sample as well.
0 Likes
User9154
Level 4
Level 4
Hi Jackson,
thank you.
1.My prefered distributor Farnell has empty stock.
Other distributors want to get + 50$ or 40€ only for post sending.... without the price of 2 pcs XMC1302T038 - see mouser, etc.
I have no contact on Infineon ś IFX sales rep or FAEs. - ///in Czech republic.
I have found no portal for samples shipping on site www.infineon.com

2. Other question: have been produced the family XMC4xxx with 65nm-technology too?
Have a nice day
zbyno
0 Likes
Not applicable
Hi zbyno,

Can you PM me your information so I could channel your request to our Marketing department.
Thank you.



Regards,
Jackson
0 Likes
User9154
Level 4
Level 4
Hi Jackson,
Thank you for answer.

My PM:
Company Name: befra / mother company bebro GmbH
Industry: electronic research- industrial solutions
Last Name: Brudny
First Name: Zbyno
Country: Czech republic
Preferred Distributor / Reseller: Farnell
Other Distributor / Reseller: Mouser
Phone: +420596496283 - office
E-mail:* zbyno.brudny@centrum.cz

have a nice day
zbyno
0 Likes
Not applicable
Hi zbyno,

Thanks for your detailed information.
I have sent your request to our Marketing department.
0 Likes
User9154
Level 4
Level 4
Hi Jackson
I got today 5 pcs. of XMC1302T038X0200A fro Mr. Baratowicz ( epcos Poland).Yet can I make a change on my KIT_XMC11_BOOT_001-board...
Thank you very much.
have a nice day
zbyno
0 Likes
Not applicable
Hi zbyno,

Great to hear that.
Hope you can get to work on with XMC1302 soon.
0 Likes
User9154
Level 4
Level 4
Hi Jackson
I have a problem. After MCU-change I can´t get BMI-value from target with Dave3.1.10 (under Keil ver5.12 J-Link worked ok, but device was not detected.
I had made a test with J-LInk GDB Server. MCU was undected too.
What is wrong?
best regards
zbyno
0 Likes
Not applicable
Hi zbyno,

Have you change the BMI from ASC Bootstrap loader (ASC BSL) to SWD?
By default from factory, the device should be in ASC BSL mode so Keil shouldnt be able to connect as well.
Can you try open J-Link commander and see if the device is detected by the J-Link?
0 Likes
User9154
Level 4
Level 4
Hi Jackson,
Yes, I have it done with J-Link commander and Commander wrote: SWD-device was undefined.
Latter I had changed (returned) Device to old XMC1100-64 on my board, and J-Link commander has read correct Device. XMC1100-64. Additionaly I have it checked with J-Link GDB Server V4.84f . He had CPU recognized XMC1100-0064 too.
Should I try other chip XMC1302T038
Have a nice day
zbyno
0 Likes
Not applicable
Hi zbyno,

I believe the XMC1302 device has not changed the BMI right?
In this case, it is correct if J-link is unable to detect the device.
What does the DAVE show you when you press the Get BMI?

Meanwhile, try to update to the latest Segger J-Link driver ( I think current version is v4.96) and also try with other XMC1302 device.
0 Likes
User9154
Level 4
Level 4
Hi Jackson,
-----What does the DAVE show you when you press the Get BMI?
unable to get BMI

Yes ,I have done all this experiments with J-Link v4.96 without success
have a nice day
zbyno
0 Likes
User9154
Level 4
Level 4
Hi Jackson,
I have used on board again other chip of XMC1302T038X0200. No success.
I got from J-Link Commander v4.96:
Firmaware J-Link-Lite-XMC4200 Rev.1 compiled Nov 28 2014...
VTarget ´3.30V....
No device found on SWD..

The widow looks identicaly with J-Commander v4.84
No ideas
zbyno
0 Likes
User9154
Level 4
Level 4
Hi Jackson,
I have used on board again other (3-th IC )chip of XMC1302T038X0200.
and ok. (I can change the BMI from ASC Bootstrap loader (ASC BSL) to SWD).
Have a nice day
zbyno
0 Likes
Not applicable
zbyno.brudny wrote:
Hi Jackson,
I have used on board again other (3-th IC )chip of XMC1302T038X0200.
and ok. (I can change the BMI from ASC Bootstrap loader (ASC BSL) to SWD).
Have a nice day
zbyno


Glad to hear that it is working now.
0 Likes